Trans trouble code P0720

Tiny
DGRIZZZ
  • MEMBER
  • BMW 740
Hello, I have a 1997 740il 183000 miles 4.4 with the zf5hp24 Trans. The trans went bad and we had it rebuilt. After reinstalling the trans and filling the fluid as to procedure. I checked for codes and had none. I took the car for a test drive and it ran great. THe only thing I noticed was a little hard down shift at one point. But over all it did great. So I get back to the shop and check codes again and now I have a P0720 Output speed sensor circuit malfuction. So my question is. Whats next. I ordered both input and output sensors. I will be installing them this Sat. I am pretty good with most thing but I need help on this sensor issue. Thanks Duane
Do you
have the same problem?
Yes
No
Wednesday, October 24th, 2007 AT 9:15 PM

3 Replies

Tiny
BMRFIXIT
  • EXPERT
Since u just replaced the tranny
1st I would check wiring for a pinch wire on or around the sensor and if all ok than I ll change the two sensors
Good luck
Was this
answer
helpful?
Yes
No
Thursday, October 25th, 2007 AT 7:23 AM
Tiny
JACK42
  • MEMBER
Not sure if this applies to your year, but those 7 series, when the ignition switch starts to go out tend to throw trans codes, might want to check all the powers out of the switch
Was this
answer
helpful?
Yes
No
Thursday, October 25th, 2007 AT 7:56 AM
Tiny
DGRIZZZ
  • MEMBER
Ok an update for you. I replaced the input and the output sensors. I cleared all codes and retest drove the car for 10 miles and returned to find no transmission :) sensor codes but found a o2 sensor code P0150 So I ordered the new 02 sensor and it is clear now. I have no codes and have been driving the car for a week now. Thank you everyone that has helped on this quest. Duane
Was this
answer
helpful?
Yes
No
Wednesday, November 7th, 2007 AT 8:00 PM

Please login or register to post a reply.

Recommended Guides