SAFE MODE

1989 BMW 535

Tiny

bacour001

March, 31, 2009 AT 9:19 PM

Transmission problem
1989 BMW 535 6 cyl Two Wheel Drive Automatic 280k miles

the transmission goes into safe mode 3 out of 5 times I start it. Seems like when its cold it doesnt go into safe mode as much. I checked the trottle sensor. Thats good. I have no idea of what else I can check/

FOUND 402 RELATED QUESTIONS

12 Answers

Tiny

Dr. Hagerty

March, 31, 2009 AT 11:59 PM

What did you expect?

Tiny

bacour001

April, 1, 2009 AT 1:04 AM

I have no idea what you mean.

Tiny

Dr. Hagerty

April, 1, 2009 AT 1:11 PM

There may be a problem with the Electronic Gearshift Selection brain. The 4HP22EH tranny is a good transmission and your problem might be software related or just a tired tranny. At 280k miles, you definitely got your moneys worth from that tranny, most of them dont make it to 200k without needing to be rebuilt. So to start, check the condition of the fluid and be sure it has the correct amount of fluid, dont rev the motor too much in park, it can damage the " A" pack and then you wont go anywhere. The next thing is to drop the pan and inspect for debris clinging to the magnets and install a new filter. Let me know what you find.

Tiny

bacour001

April, 3, 2009 AT 4:13 PM

Thanks. Ill check it out. I also do know sometimes it gets a little stuck in reverse. Maybe once every thirty times or so. When I rev the engine alittle bit it pops in to reverse. Also I have a small knocking sound coming from the front passneger side neer the wheel. Usually only last for 5 or ten seconds and goes away after picking up speed. Seems like it only happens when its in idle for a long time. But thanks again for that last reply. Ill check it out. And get back in a few days. See if we cant fix this problem. Once again thank you very much.

Tiny

bacour001

April, 3, 2009 AT 4:15 PM

Also I forgot. You might be right about the software. Every time I start my car. C heck control pops up on the dash. And headlamp prompts ont he dash. But there fine. And also, when it prompts me on the dash. Its in like german or french. Some weird language. Thanks again.

Tiny

bacour001

April, 13, 2009 AT 9:38 AM

?

Tiny

Dr. Hagerty

April, 13, 2009 AT 10:55 AM

Check the fluid level and condition. Report on the findings.

Tiny

bacour001

April, 13, 2009 AT 4:26 PM

Thats good. Somebody said it might be some sort of computer chip inside the transmission with commonly get screwy. Idk bmw are just so damn complicated. I jsut dont want to drop the trasmission if I dont have to. I mean the car runs great. It jsut keep sgoing into safe mode. Its very odd. I took it to a bmw dealership and they didint even know why. Cost me two hundred for them to pretty much check the fluid. And run a computer diagnostics test. Is there any other sort of electrical connection I could check? Once again thanks for your time and your patience. Im eager to hear your thoughts.

Tiny

Dr. Hagerty

April, 19, 2009 AT 3:13 AM

If there is an EGS issue then the transmission control unit might be the culprit here and if so the solution to this problem might be to replace/upgrade the " chip" in the brain. Let me confer with my sources and I will repost on Monday afternoon.

Tiny

bacour001

April, 20, 2009 AT 5:37 PM

Well I think your on mark with that transmission control unit. I jsut have no idea where it is located at in my car. And maybe you can refer me to a website where I might find an affordable one. Once again thanks for your time.

Please login or register to post a reply.

Read Codes Like a Pro
Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear - Dodge Stratus
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear Honda Civic
How to read codes Chevrolet Blazer
Code Read Retrieval/Clear Mercedes Benz