1996 Sunfire Electrical Problems

Tiny
MATT154
  • MEMBER
  • 1996 ALL OTHER MAKES ALL OTHER MODELS
When driving my Sunfire, a lot of my indicator lights are on (ABS, check engine, and parking brake). When I come to a stop at a red light, my radio cuts out, until I resume driving, when the radio starts up again. My brakes were just serviced, and my parking brake is not on.

Any ideas as to what the issue is with the electrical system?
Do you
have the same problem?
Yes
No
Wednesday, January 18th, 2006 AT 5:57 PM

2 Replies

Tiny
REDOY
  • MEMBER
Check your ground (-) at your battery or other end of ground (-).
Was this
answer
helpful?
Yes
No
Thursday, January 19th, 2006 AT 5:02 PM
Tiny
ARKOSE
  • MEMBER
Also, check that all of the wires you can get to are making firm connections and are not burnt or damaged. It sounds to me like either a short or a ground. Ground would probably be the first thing I would check because it is the easiest. If possible, get a wiring diagram of your car. I have a 96 sunfire as well and the Haynes manual I have has a decent diagram. You can check resistance to ground with a multimeter. The radio on and off is what would make me think it is not a ground at the battery. If the ground was at the battery it is likely you would have some trouble starting your car. Not sure how the sensors you mentioned indicate if they should be lit or not to the computer, but they may act as a digital 0, which equates to a ground or open. I am by no means a mechanic, but I know a good amount about electrical stuff, so I would say it may be as simple as a sensor gone bad or a loose wire. Since your stereo is affected, you may want to unhook it and see if there is a ground internal to the stereo. Not sure if that would affect indicator lights, but it is a relatively simple next step after checking the battery cables. Good luck! Hope that helps!
Was this
answer
helpful?
Yes
No
Friday, January 20th, 2006 AT 1:40 PM

Please login or register to post a reply.

Recommended Guides