1995 Acura Integra

Tiny
INTERGAKID
  • MEMBER
  • 1995 ACURA INTEGRA
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 179,000 MILES
I have a 1995 acura integra, it runs but my mileage odometer doesnt seem to work, the top total mileage does not move but the lower number works correctly.
Do you
have the same problem?
Yes
No
Monday, March 30th, 2009 AT 3:43 PM

2 Replies

Tiny
KHLOW2008
  • EXPERT
Hi intergakid,

The speedometer/odometer unit is faulty due to a worn or loose gear. Replacement is the only option.
Was this
answer
helpful?
Yes
No
Tuesday, March 31st, 2009 AT 1:21 PM
Tiny
JIMMYL645I
  • MEMBER
If the top mileage doesn't move and only the TRIP or LOWER milage slot moves. You can try removing the Gauge Cluster there is 3 harness on the back, try to unplug and replug them back in, take it for a drive and see if the top milage slot respond to the driving.

Sometimes it could just be loose, but if you try to unplug and replug and it does not help DOUBLE CHECK to see if any wires or ripped or torn you can try to re-wire and electrical tape it up so that it doesn't short circuit in case it comes loose.

And if you have tried both and it doesn't seem to help you can try resetting you ECU / CAR.

Go to hood lift up the fuse box on the passenger side near the battery, remove the 15amp + 7.5amp fuse for 5 mintues. This will reset all the factory settings. Who knows this might just help you, please remeber when you reset the ECU / CAR you will need to re-enter the code to the CD-PLAYER.

If none helps. I got a few RS/LS/GS/ and a extra GSR gauge cluster that are working that you can buy for cheap.

Good luck my friend.
JimmyL645i-
Was this
answer
helpful?
Yes
No
Sunday, April 19th, 2009 AT 6:31 PM

Please login or register to post a reply.

Recommended Guides