SLAVE CYLINDER FAILURE - NO CLUTCH

2009 Mitsubishi Lancer

Tiny

naijamrd

September, 12, 2012 AT 3:00 PM

I have a 2009 mitsubishi lancer 1.5L. It has leaked fluid from what looks like the slave cylinder, no pressure from the clutch therefore I cant change gears. Ive topped up the reserviour and pumped the clutch but still no pressure. Could you please confirm its the slave cylinder thats faulty before I place an order for a replacement one. Thanks

FOUND 151 RELATED QUESTIONS

6 Answers

Tiny

saturntech9

September, 12, 2012 AT 3:14 PM

Is it attached the transmission?

Tiny

naijamrd

September, 12, 2012 AT 3:26 PM

Thanks Saturntech9 for the response.
I'm a mechanical novice I'm afraid, I just know the clutch is not working (car is a manual(stick shift) by the way) I can't engage any of the gears. Hope that was helpful

Tiny

saturntech9

September, 12, 2012 AT 3:30 PM

The part leaking does it attach to the transmission?That would be the part that attaches to the engine.

Tiny

naijamrd

September, 12, 2012 AT 3:41 PM

Yes, its right at the bottom next to the engine

Tiny

saturntech9

September, 12, 2012 AT 3:42 PM

Alright then that would be the slave cylinder.

Tiny

naijamrd

September, 12, 2012 AT 3:58 PM

I have just noticed that the brakes aint working. It was rock hard until I started the engine, it went really spongy as the engine started I also noticed that the engine revvs up when I pump the brakes. Any ideas as to what this could be? Thanks

Please login or register to post a reply.

Clutch/Flywheel/Rear Main Seal Replacement
Pulling an Auto Trans? Easy Instructions