SX4 CEL light coming on

Tiny
SX4RIEDER3
  • 2008 SUZUKI SX4
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 31,000 MILES

2008 SX4 sedan - I recently got an oil change. Two days later I started the vehicle, and noticed that the check engine light comes on and flashes. When I let the enfine idle, the CEL goes off. I attempted to move the vehicle and noticed the engine was running rough. Any ideas? I have not popped the hood as I di not have time, It almost feels as if the spark plug wires are not properly making contact - just a guess.

Do you
have the same problem?
Yes
No
Monday, January 3rd, 2011 AT 1:39 PM

3 Replies

Tiny
MHPAUTOS
  • EXPERT
  • 30,953 POSTS

You will have to first go get a scan done to identify the set fault code as indicated by the MIL, post that code here for further assistance.

Mark (mhpautos)

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, January 3rd, 2011 AT 2:34 PM
Tiny
SX4RIEDER3
  • MEMBER

Fault code pulled is PO302, Misfire on Cylinder #2. From what the mechanic told me it is under warranty, so I have to take it to the dealership and they do not have an appointment until 1/7/2011. The CEL no longer displays and the engine idles fine. Is it safe to drive? Please advise. Thanks.

Was this
answer
helpful?
Yes
No
Tuesday, January 4th, 2011 AT 5:44 PM
Tiny
MHPAUTOS
  • EXPERT
  • 30,953 POSTS

Yes it should be OK to drive until then

mark (mhpautos)

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Friday, January 7th, 2011 AT 2:11 PM

Please login or register to post a reply.

Related Check Engine Soon Light Questions

Help us by donating