AC compressor starts automatically even if AC is OFF.

Tiny
MUHIB_J
  • MEMBER
  • 2008 MITSUBISHI LANCER
  • 55,000 MILES

When I start my car and keep for heating, sometimes I hear a noise of trip and compressor starts, and clutch (below the belt) also start rotating.
Is this normal even if AC buttons are oFF in the car.

Do you
have the same problem?
Yes
No
Monday, August 29th, 2011 AT 6:31 AM

7 Replies

Tiny
KHLOW2008
  • EXPERT
  • 42,192 POSTS

This is not normal for your vehicle according to specifications as stated in our database. If the A/C switch is not turned on, the compressor should not engage.

Was this
answer
helpful?
Yes
No
Monday, August 29th, 2011 AT 2:14 PM
Tiny
MUHIB_J
  • MEMBER

Thanks for the reponse.
Please let me know how to solve this AC problem.
What checkups do I need to do or what to be replaced.
Regards.

Was this
answer
helpful?
Yes
No
Friday, September 2nd, 2011 AT 3:28 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,192 POSTS

Is your A/C system manual or automatic control?

Was this
answer
helpful?
Yes
No
Friday, September 2nd, 2011 AT 5:26 PM
Tiny
MUHIB_J
  • MEMBER

AC system is automatica I guess. Please tell me what to do to sort the problem. Also let me know if it is manual thn wat to do.

Was this
answer
helpful?
Yes
No
Tuesday, September 13th, 2011 AT 8:56 AM
Tiny
KHLOW2008
  • EXPERT
  • 42,192 POSTS

Whether manual or automatic system, the A/C compressor gets its power supply from the A/C compressor relay and there are 3 possibilities for the relay to be energised.

1. Faulty relay. It is self triggering intermittently and contacting to provide power to the compressor. Try swapping out the compressor relay with the fog light relay and see if problem goeas away.

2. A short in the grounding circuit of the compressor relay. You would need to test orange wire for shorting.

3. Faulty PCM. It is grounding the relay intermittently.

Was this
answer
helpful?
Yes
No
+1
Tuesday, September 13th, 2011 AT 12:00 PM
Tiny
HILARIO ARANDA
  • 1998 MITSUBISHI LANCER
  • 1.3L
  • 4 CYL
  • 2WD
  • MANUAL
  • 300,277 MILES

Dear sir,
when I start the engine and turn on the A/C the fan and auxiliary fan runs only for seconds then it will stop running. My question is, what is the cause and how could I fix it? Is it the fuse or the clutch of compressor?
Second question, my car running with black smoke I dismantling and cleaned already the carburetor but still black smoke is coming please help. God bless you.
Thanks

Was this
answer
helpful?
Yes
No
Wednesday, November 1st, 2017 AT 10:34 AM (Merged)
Tiny
MHPAUTOS
  • EXPERT
  • 31,947 POSTS

The A/C system may be low on refrigerant, this will have to be checked by a mechanic with the correct equipment. If low there will be a leak that will require attention, you cannot just add refrigerant yourself as there is an exact weight required to run the system, too much or too little and the system will shut down. As for the black smoke, this will be over rich, if your car is a carburetor model, the float level may be too high causing flooding, something that a mechanic or someone with carburetor experience needs to look at, as the adjustments are very precise.

Was this
answer
helpful?
Yes
No
Wednesday, November 1st, 2017 AT 10:34 AM (Merged)

Please login or register to post a reply.

Recommended Guides