My blower switch only works on the on the first.

Tiny
NICK PETERS
  • 2007 GMC ENVOY
  • 60,000 MILES

My blower switch only works on the on the first three settings, number 4 & 5 are dead. Is it the switch or some other assembly? I've looked on Rockauto. Com but I'm not sure of what part to order and I can't afford to go to a dealer.

Do you
have the same problem?
Yes
No
Monday, February 11th, 2013 AT 1:07 PM

5 Replies

Tiny
ASEMASTER6371
  • EXPERT
  • 25,533 POSTS

Blower resistor. Check the dealer parts. They are cheaper than you think sometimes.

Make sure you replace the connector as well.

Roy

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, February 11th, 2013 AT 1:15 PM
Tiny
NICK PETERS
  • MEMBER

Is this a project I can tackle? I'm a car guy, but I know more about a '32 Ford Roadster than an Envoy.

Was this
answer
helpful?
Yes
No
Monday, February 11th, 2013 AT 1:18 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,533 POSTS

Yep, easy repair

roy

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, February 11th, 2013 AT 1:21 PM
Tiny
NICK PETERS
  • MEMBER

Thanks.

Was this
answer
helpful?
Yes
No
Monday, February 11th, 2013 AT 1:24 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,533 POSTS

Good luck

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, February 11th, 2013 AT 1:27 PM

Please login or register to post a reply.

Related Heater Switch Questions

Help us by donating