2007 Dodge Magnum ODBII codes P0660 P2017 P2078

Tiny
CALIMAGNUMDAD
  • MEMBER
  • 2007 DODGE MAGNUM
  • 3.5L
  • V6
  • 2WD
  • AUTOMATIC
  • 173,000 MILES
My 07 magnum check engine light started coming on and then would go off on its own. This occurred a number of times, so while it was on one of these times I got the code read came back a p0660 which I found out is a voltage irregularity with the intake manifold tuning valve, as it was not running bad and a majority of the time the check engine light was off so it was not a big deal. Then the check engine light came on and stayed on and now I need to get a smog test done. I have gotten 2 more codes from the initial smog test a p2017 and a p2078 in addition to the p0660, I swapped out the MTV and check engine light is still on so I checked the wiring harness visually as well as the connectors, and didnt see any obvious issues I disconnected the harness at the big 14 pin connector on the left side of the engine compartment and did some continuity checks and found that 2 wires on the female connector were showing there connected to each other I am not sure if they are supposed to be in circuit with each other or not if your looking at the female end with the 4 empty spots being 1, 2, 3, and 4 like this:
1, 2, 3, 4, 5, 6, 7,
8, 9, 10, 11, 12, 13, 14 then the wires at spot 5 and 10 when tested had continuity, I am desperate dont have the funds to go to a mechanic so I have to fix it myself but I am stuck can anyone please help me figure this out. If you need any more info please let me know its a V6 3.5L Thank you in advance for any help you can provide.
Do you
have the same problem?
Yes
No
Sunday, August 10th, 2014 AT 7:18 AM

10 Replies

Tiny
HMAC300
  • EXPERT
Frst any time you need the light to go out you need a scanner autoparts have them so anytime apart is changed dn light is still on it needs the scanner to shut it off. All those codes relate to the MTV valve so having codes erased and riving is only way to find out if it' s fixed or not.
Was this
answer
helpful?
Yes
No
+1
Sunday, August 10th, 2014 AT 8:45 AM
Tiny
CALIMAGNUMDAD
  • MEMBER
Ok cleared the code and the light came back on while driving stayed off for a few came back on when we cleared the code again and started it up after the light came on right away I have been working on this all week desperate please help, or will trade for $2500 and a minivan or 6k.
Was this
answer
helpful?
Yes
No
+1
Sunday, August 10th, 2014 AT 12:37 PM
Tiny
CALIMAGNUMDAD
  • MEMBER
I went out disconnected the positive and negative from the battery then disconnected the mtv unbolted it pulled it off made sure it turned freely put it back in after I moved the flap manually put the mtv back in the slot twisted it so it was lined up correctly bolted it up reconnected it and then the battery and turned the car on light is off and staying off still need to drive it but before after I cleared the code light came back on immediately this time it did not im so frustrated and desperate please please someone tell me what is the issue this is my only transportation need to register it and don't have funds to go to a mechanic have 4 kids and need my ride to get to work does anyone have any idea what it could be or have ever dealt with this before
Was this
answer
helpful?
Yes
No
Sunday, August 10th, 2014 AT 1:02 PM
Tiny
HMAC300
  • EXPERT
What code is it now the same one? On the back of the pin connector will be the numbers not like you have listed see pics
Was this
answer
helpful?
Yes
No
+1
Sunday, August 10th, 2014 AT 1:03 PM
Tiny
CALIMAGNUMDAD
  • MEMBER
The connector I was referring to is the one that supplies the connectors pictured I will try the steps that you have posted and see what I am able to find thank you and yes its the same p0660 code. Again thank you so very much for the info I appreciate it very much.
Was this
answer
helpful?
Yes
No
Sunday, August 10th, 2014 AT 1:16 PM
Tiny
CALIMAGNUMDAD
  • MEMBER
When I performed the tests you posted the resistance came back at 5 ohms on the dot the test light however did not illuminate.
Was this
answer
helpful?
Yes
No
Sunday, August 10th, 2014 AT 1:29 PM
Tiny
CALIMAGNUMDAD
  • MEMBER
So if you dont mind and have the info could you tell me how I would fix this I can get wire remove the bad wire and replace it or do I need to remove and get another wire harness? Since the only thing effected is ythis module is it safe to assume that this wire only goes to this connector or is it connected to other things as well?
Was this
answer
helpful?
Yes
No
Sunday, August 10th, 2014 AT 1:42 PM
Tiny
CALIMAGNUMDAD
  • MEMBER
Ok well I just did it lol I cut the wire at the 14 pin connector and the MTV connector and spliced in new wire from the 14 pin connector to the mtv connector lights off going for test drive now.
Was this
answer
helpful?
Yes
No
+1
Sunday, August 10th, 2014 AT 2:23 PM
Tiny
CALIMAGNUMDAD
  • MEMBER
Ok that didnt work check engine light stayed off but began running like crap lightning bolt became illuminated and car with swervy squiggles as well so that wire is connected to other things as well so now I dont know whayt to do
Was this
answer
helpful?
Yes
No
Sunday, August 10th, 2014 AT 2:48 PM
Tiny
HMAC300
  • EXPERT
Ke ito a pro mechanic and have him scan it as he can do a lot with the scanner as far as check ing the problem. I have no further suggestions.
Was this
answer
helpful?
Yes
No
Sunday, August 10th, 2014 AT 6:24 PM

Please login or register to post a reply.

Recommended Guides