ABS Light

Tiny
THADIUS
  • MEMBER
  • 2006 CHEVROLET COBALT
Ive got the ABS and red brake warning lamp on when I drive it the light stays on I fixed the brake lines and bled them but it stayed on but today it went off when I geared down whats the cause of this?
Do you
have the same problem?
Yes
No
Friday, September 27th, 2013 AT 10:27 AM

4 Replies

Tiny
SATURNTECH9
  • EXPERT
It sounds like you have a ABS wheel speed sensor that is going out but to be sure let run the codes here is a video to help.

https://youtu.be/rTtAnsOlZU4

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
Friday, September 27th, 2013 AT 11:55 AM
Tiny
SHANNON_PRIV
  • MEMBER
Thanks for this post I had this problem found the right front wheel sensor has out got a new one for $76.00 all set!
Was this
answer
helpful?
Yes
No
Wednesday, July 17th, 2019 AT 1:18 PM
Tiny
JAMESPALEN
  • MEMBER
  • 2005 CHEVROLET COBALT
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 99,000 MILES
While replacing a broken wheel stud (driver's side front) on my girlfriend's 2005 Chevy Cobalt, I had to unplug the ABS wiring located above the spindle so I could pull out the hub. I plugged the two ends back together after putting the hub back in place, but now the ABS light on the dash panel is lit. She is pretty sure it wasn't on before I did the work, so I was wondering if a temporary lighting of the light is normal after the unpluggling. If so, can I take it to the dealer to have them remove the code and reset the system? If it doesn't seem normal, then what could be the problem if the wiring, at least on its exterior, appears undamaged? Could I have caused it?
Was this
answer
helpful?
Yes
No
Thursday, July 18th, 2019 AT 9:14 AM (Merged)
Tiny
BMRFIXIT
  • EXPERT


http://www.2carpros.com/forum/automotive_pictures/99387_Graphic1_233.jpg



The sensor is part of the wheel bearing and hub
if the wire OK and its plugged back in
I would suspect that the sensor was damaged when the hub was removed
try and drive it around if the light go out you r good
if not need to have it scanned for codes
let me know what you have for codes
I would suspect a bad wheel sensor
since u had no light until hub was removed
Was this
answer
helpful?
Yes
No
Thursday, July 18th, 2019 AT 9:14 AM (Merged)

Please login or register to post a reply.

Recommended Guides