Flashing "Service Engine Soon" light

Tiny
BLUEM
  • MEMBER
  • 2006 BMW X5
  • V8
  • AWD
  • AUTOMATIC
  • 82,000 MILES
Today I started my 2005 X5 4.4i and noticed that the "Service Engine Soon" light was flashing. I turned the X5 and started 2 more times but the light never came back on.

The first time I started the X5 I noticed a strange sound from the engine as if it was losing RPM.

Any input is appreciated.

Thanks.B

Few times during the past month I also noticed that when I start the X5 in the morning, the engine sound changes as if it is going to turn off which lasts 5-10 seconds.
Do you
have the same problem?
Yes
No
Monday, December 6th, 2010 AT 4:08 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
What you need to do is wait until the light is on and have the computer scanned to identify where the problem is coming from. Most parts stores will do it for free. Also, since the engine seems to want to stall, have the idle air control valve checked as well as check for vacuum leaks.
Was this
answer
helpful?
Yes
No
-1
Monday, December 6th, 2010 AT 4:15 PM
Tiny
BLUEM
  • MEMBER
Thanks for your reply. Should I be concerned if the Service Engine Soon light does not come on any more? Because it went away after I 2 starts.

The engine stall only happens when I truned on in the morning.
Was this
answer
helpful?
Yes
No
Monday, December 6th, 2010 AT 9:51 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If the light is off, there shouldn't be a concern.
Was this
answer
helpful?
Yes
No
+1
Tuesday, December 7th, 2010 AT 4:27 PM

Please login or register to post a reply.

Sponsored links