2005 Ford five hundred. It just keeps dying

Tiny
AZKID
  • MEMBER
  • 2005 FORD 500
  • 3.0L
  • 6 CYL
  • AWD
  • AUTOMATIC
  • 150,000 MILES
We have replaced the alternator and the battery yesterday and it is still saying check charging system.

Mileage is 150,000 we were driving, the checking charging system sign popped up we drove home Frankie sat in the car for a min listening to the radio and it completely died we tried to jump it and it didn't work we replaced the alternator it ran for about an hour and died again with no restart we checked the battery and it was bad so we replaced it. After that it started right up but when I backed it up and put it in drive it died and said check charging system. It will start but just dies now.
Do you
have the same problem?
Yes
No
Sunday, August 31st, 2014 AT 10:21 PM

3 Replies

Tiny
WRENCHTECH
  • EXPERT
Has anyone tested the charging system before throwing parts at it?

You need to test the charging system in the car with the car running. Have the battery charged and tested first.
Was this
answer
helpful?
Yes
No
Monday, September 1st, 2014 AT 4:28 AM
Tiny
AZKID
  • MEMBER
Ok thanks, but if that's not it, any other ideas?
Was this
answer
helpful?
Yes
No
+1
Monday, September 1st, 2014 AT 10:37 AM
Tiny
WRENCHTECH
  • EXPERT
I didn't diagnose anything. You first need to know if the car is recharging the battery or not. If not then you have to determine why. If it is, then we have to look elsewhere for the problem.
Was this
answer
helpful?
Yes
No
-1
Monday, September 1st, 2014 AT 11:45 AM

Please login or register to post a reply.

Recommended Guides