How do I repair

Tiny
AGUAYO3371
  • MEMBER
  • 2005 DODGE NEON
  • 94,320 MILES
Po731 po500 speedometer not working gas gadge acting up going from quarter to empty I have already changed the inner and outer speed sensor all started when the car ignition switch failed I replace it and now starts now it's no going into differt gears just in limp mode
Do you
have the same problem?
Yes
No
Monday, November 21st, 2011 AT 5:45 AM

7 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
731 gear ratio error 1st gear. If you replaced the sensors, check wiring and check for corrosion, damage.
Was this
answer
helpful?
Yes
No
Monday, November 21st, 2011 AT 5:55 AM
Tiny
RASMATAZ
  • MEMBER
Recheck the vehicle speed sensor
Was this
answer
helpful?
Yes
No
Monday, November 21st, 2011 AT 6:05 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
PO500 is a speed sensor issue. As Raz mentioned, recheck the wiring, plug. To the speed sensor.
Was this
answer
helpful?
Yes
No
Monday, November 21st, 2011 AT 6:16 AM
Tiny
AGUAYO3371
  • MEMBER
I just checked both the inner the outer sensor connecters is there any way to see if they are powering up
Was this
answer
helpful?
Yes
No
Monday, November 21st, 2011 AT 6:34 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
The problem is they work on what is called a hall effect. Basically, the sensor is a magnut which produces a current when a steel ring passes it.
Was this
answer
helpful?
Yes
No
Monday, November 21st, 2011 AT 6:49 AM
Tiny
AGUAYO3371
  • MEMBER
One more? Please if the transmiton shift silinoid is bad will that make the speedometer not work?
Was this
answer
helpful?
Yes
No
Monday, November 21st, 2011 AT 7:11 AM
Tiny
RASMATAZ
  • MEMBER
Check the wiring for short and open circuit going back to the computer if okay could be the computer itself
Was this
answer
helpful?
Yes
No
Monday, November 21st, 2011 AT 5:26 PM

Please login or register to post a reply.

Recommended Guides