2005 Chevrolet Avalanche Engine cooling fan

Tiny
MBHENRY
  • MEMBER
  • 2005 CHEVROLET AVALANCHE
  • 5.3L
  • V8
  • 4WD
  • AUTOMATIC
  • 90,000 MILES
My A/C started cycling warm and cold air. I put gauges on the system and they are reading normal in the A/c Auto position. But when I raised the RPM's to about 1500 I noticed that the Hi pressure got to about 300 psi.
But I noticed that the engine cooling fan did not come on with the A/C.
Once the engine temp called for the engine fan to come on the high pressure came down and the temp out of the vents cooled down.
I have no schematics, so where do I look for the relay/fuse/switch that turns on the fan when the A/C compressor comes on?
Thanks
Do you
have the same problem?
Yes
No
Wednesday, August 27th, 2014 AT 4:56 AM

4 Replies

Tiny
HMAC300
  • EXPERT
Fuses and relay are under hood for the fan. Also pull havc fuse inside truck your temp actuators may need to reset or they are going bad.
Was this
answer
helpful?
Yes
No
+1
Wednesday, August 27th, 2014 AT 6:16 AM
Tiny
MBHENRY
  • MEMBER
I will ck the hvac fuses and relays, but how do I reset the actuators?
Was this
answer
helpful?
Yes
No
Wednesday, August 27th, 2014 AT 6:39 AM
Tiny
HMAC300
  • EXPERT
I forgot to put that in lol. Pull hvac fuse for 60 seconds with key on then reinstall. They will reset sometimes but not all the time. Sorry.
Was this
answer
helpful?
Yes
No
Wednesday, August 27th, 2014 AT 7:17 AM
Tiny
MBHENRY
  • MEMBER
LOL.
Thanks
Was this
answer
helpful?
Yes
No
Wednesday, August 27th, 2014 AT 8:27 AM

Please login or register to post a reply.

Recommended Guides