Engine bucking or********

Tiny
BRACEB
  • MEMBER
  • 2004 MERCURY MOUNTAINEER
  • V8
  • AWD
  • AUTOMATIC
  • 97,000 MILES
No repairs have ever been made to this vehicle to my knowlege. It has 97,000 on 40,000 of which I have put on it.I recently changed the oil. About 100 miles ago. Today while driving my engine started bucking when I hit 50mph stopped when I slowed, but started again when I picked up speed.I was on the highway and was about 5 miles from so continued driving then an engine override light came on. What is happening. It runs and Idles(has a slight surge when Idling)
Do you
have the same problem?
Yes
No
Wednesday, January 12th, 2011 AT 1:35 AM

3 Replies

Tiny
LEGITIMATE007
  • EXPERT
Scan the engine for codes and bring back to me
Was this
answer
helpful?
Yes
No
Wednesday, January 12th, 2011 AT 7:24 PM
Tiny
BRACEB
  • MEMBER
I had the vehicle scanned at auto zone. No codes came up.I filled my tank put in a can of heet seem to run fine. Gotgas mileage has gone down from 18 to 12 mpg. It stalled out once at a stop light. It did start again.I was able to get home. The engine surges slightly at idle about 50 rpm when idling. Could my fuel pump be going?
Was this
answer
helpful?
Yes
No
Sunday, January 16th, 2011 AT 5:04 AM
Tiny
LEGITIMATE007
  • EXPERT
It could be, but you need to check fuel pressure, and I would also check the iac. And clean out the throttle body, I think the iac may be eratically, and one more thing, the mass airflow sensor, may be faulty or just need cleaning.(There is a special spray for that.
Was this
answer
helpful?
Yes
No
Sunday, January 16th, 2011 AT 3:00 PM

Please login or register to post a reply.

Sponsored links