I CHANGED MY BENZ C240 2003 MAKE ENGINE ITS GIVING A ERROR CODE PO175

  • Tiny
  • Amarsandhu
  • 2003 MERCEDES BENZ C240
  • 80,000 MILES

Idle speed cannot control rpm is 10000 when I start

Do you
have the same problem?
Yes
No
Wednesday, February 8th, 2012 AT 4:57 AM

5 Replies

  • Tiny
  • Rasmataz
  • MEMBER

Running rich and also look for vacuum leak

Was this
answer
helpful?
Yes
No
Wednesday, February 8th, 2012 AT 5:06 AM
  • Tiny
  • Rasmataz
  • MEMBER

Its running to rich check oxygen and coolant temperature sensor and also look vacuum leak

Was this
answer
helpful?
Yes
No
Wednesday, February 8th, 2012 AT 5:11 AM
  • Tiny
  • Rivermikerat
  • MEMBER

10,000RPM? Hard to believe.
Our reference doesn't show a P0175. I have found a number of mentions of this code in conjunction with a P0172. This means the air/fuel ratio is too rich. Check the fuel pressure. Check for a clogged air filter. Check the gap on the spark plugs(.039) and the plug wire impedance. MBZ doesn't supply shops with a specification for this, but expect in the range of 14Kohms to 20Kohms.

Was this
answer
helpful?
Yes
No
Wednesday, February 8th, 2012 AT 5:13 AM
  • Tiny
  • Rivermikerat
  • MEMBER

Yargh. You beat me again. Walk the plank!

Was this
answer
helpful?
Yes
No
Wednesday, February 8th, 2012 AT 5:23 AM
  • Tiny
  • Rasmataz
  • MEMBER

Got ya

Was this
answer
helpful?
Yes
No
Wednesday, February 8th, 2012 AT 5:31 AM

Please login or register to post a reply.

Other Engine Replace/Remove Questions