03 , 3.1, ROUGH IDLE AND TAPPING SOUND, SHOWS MISFIRE AND O2 SENSOR

2003 Chevrolet Malibu

Tiny

firefighteres755

April, 4, 2012 AT 3:49 PM

Today, the car suddenly started running rough and makes a tapping noise. Accelerating seems to smooth out the roughness, but not the noise. Noise seems to be coming from under the intake right about in the middle. Engine scan revealed a "Cylinder 6 Misfire" and O2 sensor.

- Checked #6 plug, it was clean. Regapped to.060 and reinstalled.
- Removed coil pack and inspected. No cracks, produces spark
- Plug wires are new, power does go to the plug
- Good fuel pressure
- Not using (burning) coolant, no apparent air leaks

Now I'm stumped!

FOUND 1493 RELATED QUESTIONS

4 Answers

Tiny

hmac300

April, 4, 2012 AT 7:41 PM

Check your fuel pressure and you may have a lifter going bad on itmaking the noise. We can't hear it so can't really diagnose it.

Tiny

fixitmr

April, 4, 2012 AT 8:39 PM

Do a compression test?

Tiny

firefighteres755

April, 4, 2012 AT 9:24 PM

No, I didn't do a compression test on it. It does sound like a lifter ticking, but without removing the intake manifold I couldn't tell.

When this happened, my wife was driving, came to a 4-way stop, and it started as she was taking off. At that time is when it started running rough and making the tapping noise and the check engine light started.

The plugs were in good shape. Like new, as well as the cables. Coil packs were in good shape, and there was good spark. All the hoses seemd to be good, and no evidence of any air or coolant leaks.

Thank you for your answers!

Tiny

fixitmr

April, 5, 2012 AT 5:50 PM

Maybe a valve spring broke? Might as well pop cover and look things over?

Please login or register to post a reply.

Oxygen Sensor Replacement Dodge Stratus
Oxygen Sensor Replacement Honda Civic 1996-20
Fail Your Smog Test? Fix it Fast
 Step by Step video GMC Yukon XL 2000-2006
Read Codes Like a Pro
Code Read Retrieval/Clear Mercedes Benz