Misfires

Tiny
2ARUBA
  • MEMBER
  • 2003 AUDI A4
  • 6 CYL
  • AWD
  • MANUAL
  • 120,000 MILES
Issues with my 2003 A4 3.0. Took car to Audi for engine light, they found misfires on cylinders 4, 5 and 6. All ignition coils replaced, new spark plugs, replaced Coolant Temp sensor, repaired crankcase vacuum hose. Light came back on, replaced Evap purge Valve and then replaced one Catalytic converter (Bank 1) due to it being under threshold. Still showing misfires! Now they want to replace the Engine Control Module, but aren't sure this will correct the problem. Well over $3000 in repairs already. Any advice? I am feeling like I am being taken for a ride here.
Edit/Delete Message
Do you
have the same problem?
Yes
No
Sunday, February 6th, 2011 AT 1:50 AM

2 Replies

Tiny
JLG
  • MEMBER
I have the same model with the same engine(2003 A4, 3.0 engine). Mine has 122,000 miles and I'm having very similar issues. Please leave a response if you find out any information. Thank you!
Was this
answer
helpful?
Yes
No
Wednesday, February 16th, 2011 AT 9:49 PM
Tiny
2ARUBA
  • MEMBER
They replaced the ECM, and so far, so good. The car is running well and the check engine light has not come back on. I'm keeping my fingers crossed. They said the computer was reading misfires when the car was not actually misfiring, thus a faulty ECM. I would have it checked, you may have the same issue. Expensive repair at Audi, about $900.
Was this
answer
helpful?
Yes
No
Thursday, February 17th, 2011 AT 12:46 AM

Please login or register to post a reply.

Sponsored links