2002 Saturn Vue Speedometer issue

Tiny
X2006NZL
  • MEMBER
  • 2002 SATURN VUE
Hi all i'm at my wits end with my vue, I had a minor fender bender to the front end of my vue going avout 20km/hr, minimal damage to the front dont know if its relevant but figured I would include it incase it helps
also I previously always had a service wrench light after a few seconds of being put in gear or if my foot was on the brake pedal after a few seconds
heres the story
i was driving on the highway everything was working fine and then the speedometer started flickering and then died completely i'm assuming that the speedometer runs the transmission?
as I can only go so fast and then it jolts and bucks any idea what the issue is?
thanks for all your help

i should also add is a 02 saturn vue 3.0l with automastic transmission
thanks
Do you
have the same problem?
Yes
No
Wednesday, July 24th, 2013 AT 1:15 PM

10 Replies

Tiny
SATURNTECH9
  • EXPERT
I need you to have it scanned for codes and let me know the exact cod numbers not code descriptions. Thats are starting point.
Was this
answer
helpful?
Yes
No
Wednesday, July 24th, 2013 AT 6:35 PM
Tiny
X2006NZL
  • MEMBER
Alright I just scanned it with my innova 3130 no codes, I know gms tech 2 scanner will scan them but I dint want to pay 100 also I have the identical vue for parts, what could it be speed sensor etc?
Thanks
Was this
answer
helpful?
Yes
No
Thursday, July 25th, 2013 AT 3:50 AM
Tiny
SATURNTECH9
  • EXPERT
Does your scan tool show live data?If so does it show vechile speed?
Was this
answer
helpful?
Yes
No
Thursday, July 25th, 2013 AT 7:20 AM
Tiny
X2006NZL
  • MEMBER
Hi thanks for the reply, yes my scanner shows live data, vehicle speed is shown 0 at startup if you put ijn drive and go it goes for 1-2 sesonds then dies to zero just like the guage
thanks
Was this
answer
helpful?
Yes
No
Thursday, July 25th, 2013 AT 8:55 AM
Tiny
SATURNTECH9
  • EXPERT
I would start by checking the speed sensor. Do you have a multi meter to do some testing?
Was this
answer
helpful?
Yes
No
Thursday, July 25th, 2013 AT 11:48 AM
Tiny
X2006NZL
  • MEMBER
Yes I have a multimeter to do some testing how do I test it,
also btw to check a few things I changed speed sensors, changed bcm, changed tcm from my parts vue but still no speedometer
thanks and where does the wiring from the sensor go?
Thanks
Was this
answer
helpful?
Yes
No
Thursday, July 25th, 2013 AT 12:09 PM
Tiny
SATURNTECH9
  • EXPERT
We really need to get codes otherwise we could guess for days the codes are always the starting point for problems like this.
Was this
answer
helpful?
Yes
No
Thursday, July 25th, 2013 AT 7:30 PM
Tiny
X2006NZL
  • MEMBER
Alright so are you leaning towards the speed sensor on the passenger front hub, where does that wire lead to and how do I check it any diagrams?
Thanks
Was this
answer
helpful?
Yes
No
Friday, July 26th, 2013 AT 3:38 AM
Tiny
X2006NZL
  • MEMBER
Hi so I tried the following,
BCM was changed,
TCM was changed,
Wheel speed sensor was changed,
Short wire from sensor to fender was changed and tested for continuity,
Wire with connecter from fender to firewall was changed and tested for continuity,
I found the control module right behind the shifting assembly the orange like relay removed electrical contacts cleaned and swapped from parts vehicle,
still the same thing, what's next swap out ecm's?
Thanks
Was this
answer
helpful?
Yes
No
Friday, July 26th, 2013 AT 1:56 PM
Tiny
X2006NZL
  • MEMBER
I swapped out the ecm, no difference and then I checked the voltages for the Wheel Speed Sensor Conditioner Module (WSSCM)
Was this
answer
helpful?
Yes
No
Friday, July 26th, 2013 AT 4:17 PM

Please login or register to post a reply.

Recommended Guides