Need a Saturn expert for this one

Tiny
JENN7480
  • MEMBER
  • 2002 SATURN SL2
  • 16,000 MILES
I have a 2002 saturn sl2 with about 160k on it. I have no acceleration power to it (goes about 20 tops before the ses light starts flashing). I took it to an auto parts shop to hook up to a computer. It spit out the camshaft position sensor thing (now even I know my car doesn't have one). And the o2 sensor went off too. What I want to know is, is this a simple fix of just changing the plugs and wires or is it something like a fuel pump? The car does a little "shake" while it's in drive while my foot is on the break. Is it worth taking to a shop to tell them to change the plugs/wires or is it better to just junk the dang thing and start over?
Do you
have the same problem?
Yes
No
Monday, March 19th, 2012 AT 2:30 AM

9 Replies

Tiny
SATURNTECH9
  • EXPERT
With the ses light flashing you should have more then a O2 sensor code and cam signal code.A flashing ses light usually means you have a major missfire that can damage the cat.I need the exact code numbers you have not code descriptions. You are correct the car doesnt have a cam sensor when that code happens you usually have black carbon on the spark plug wire end where it goes on the spark plugs. So most likely plugs and wires and if there bad enough it can cause the flashing ses light. Also do not let anyone put platnuim plugs in that engine they carbon foul in that engine.I recomend copper ngk plugs and a good set of wire like ac delco bosch nippon denso etc. The wires and plugs are easy to change you just change one wire at a time so you dont get them mixed up.
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 2:47 AM
Tiny
JENN7480
  • MEMBER
The codes are in my car. I can get them tomorrow. It was the exact 340 341 or whatever the code is (440 441?) That was the cam shaft sensor and the o2 sensor. The o2 sensor was secondary to the cam shaft thing. Can plugs really do that much for the acceleration? Thanks so much in advance. I'll get you the codes soon.
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 2:51 AM
Tiny
SATURNTECH9
  • EXPERT
The P0440 is a evap code so please get me the exact codes. Also yes bad wires and plugs can cause the engine to run really bad.
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 2:57 AM
Tiny
JENN7480
  • MEMBER
Let me take a walk to my car and grab them. Thanks for the fast replies. I really appreciate them!
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 3:03 AM
Tiny
SATURNTECH9
  • EXPERT
No problem let me know what codes you have.
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 3:07 AM
Tiny
JENN7480
  • MEMBER
Codes P0340 and P0341
O2 sensor was possibly a result of the
first 2 so he didn't write the number down.
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 3:30 AM
Tiny
SATURNTECH9
  • EXPERT
Those P340 codes dont usually go hand and hand with O2 sensor codes. Lets check out the plugs and wires and go from there.
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 3:40 AM
Tiny
JENN7480
  • MEMBER
Thanks! I will keep you posted!
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 3:46 AM
Tiny
SATURNTECH9
  • EXPERT
Alright let me know.
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 4:03 AM

Please login or register to post a reply.

Recommended Guides