2002 Saturn L300 Saturn problem

Tiny
DEANNABABS
  • MEMBER
  • 2002 SATURN L300
  • V6
  • FWD
  • AUTOMATIC
  • 48,000 MILES
I'm having a problem with my Saturn L300. It has less than 50,000 miles on it. I was driving it and the speedometer pin dropped to zero and the wrench light came on and the service engine light came on and then it would not accelerate. I was pressing the gas and it would not move, almost like I was in neutral. My mechanic can not figure out the problem. It happened to him. Except he drove it for about 4 miles and then pressed the gas to go and it won't move. It starts right up. Everything seems to be working fine and then all of a sudden you press the gas and it does not move
Do you
have the same problem?
Yes
No
Monday, December 1st, 2014 AT 5:34 PM

3 Replies

Tiny
SATURNTECH9
  • EXPERT
Alright I need to know the exact numbers not code descriptions that are in the computer from the service light coming on? That would would really help me have a starting point on whats going on.
Was this
answer
helpful?
Yes
No
Monday, December 1st, 2014 AT 5:59 PM
Tiny
DEANNABABS
  • MEMBER
Ok thank you for getting back to me. Unfortunately I don't know the codes. I can ask my mechanic tomorrow when I pick up the car. He can't fix it so I have to pick it up
Was this
answer
helpful?
Yes
No
Monday, December 1st, 2014 AT 6:09 PM
Tiny
SATURNTECH9
  • EXPERT
Alright let me know what they are.
Was this
answer
helpful?
Yes
No
Tuesday, December 2nd, 2014 AT 6:15 AM

Please login or register to post a reply.

Recommended Guides