NEW BATTERY NO POWER?

2001 Lexus IS 300

Tiny

armando123456

October, 14, 2012 AT 8:50 PM

My battery was low, when I turned the key car still had power just not enough to start, it was a old battery so I bought a new one just after a few minutes of checking the old battery, now I connected the new battery and its charged but when I turn the key I have no power no lights nothing. Whats wrong? It at least turned the dash lights with old battery

FOUND 2030 RELATED QUESTIONS

8 Answers

Tiny

ASEMaster6371

October, 14, 2012 AT 8:52 PM

Check your cable connections for clean solid connections

Roy

Tiny

armando123456

October, 16, 2012 AT 1:40 AM

I check them, there ok they have electrical current, cleaned the conectors, car had power and worked all day before old battery went low, all I did was disconnect old one connect new one. I check fuses there ok, still no power, what else can it be?

Tiny

ASEMaster6371

October, 16, 2012 AT 1:42 AM

Did you cross the cables installing the battery?

Roy

Tiny

armando123456

October, 16, 2012 AT 1:45 AM

No, battery has power, positve to positve negative to negative, I just dont have power nothing comes on, no noise nothing.

Tiny

CJ MEDEVAC

October, 16, 2012 AT 2:44 AM

I THINK HE WANTS TO KNOW IF YOU ACCIDENTALLY CROSSED THEM (EVEN FOR A SPLIT SECOND)

IF YOU ATTEMPTED A "JUMP START"--DID SOMETHING POSSIBLY GET CROSSED UP---OR ARCED?

WITHOUT SUPER ACCURATE INFO ASEMaster6371 MIGHT GUESS FOR THE NEXT 3 DAYS

RIGHT NOW LOOKS LIKE HE MAY HAVE SOMETHING TO GO ON. DEPENDING ON YOUR ANSWER

THE MEDIC

Tiny

armando123456

October, 18, 2012 AT 1:15 AM

Oh ok, no, I did not, I made sure I connected it right, I have not tried to jump start it since the battery is new, I know its hard to understand but I am giving you all the info, my car is just sittin now havnt tried nothn else, all I know, my old battery gave me power at least to my accesories, ect, disconected the old one put a new one in and bam no power, thats where im at. Im stumped. Thanks for all the info guys

Tiny

CJ MEDEVAC

October, 19, 2012 AT 4:49 AM

TIME TO GET SERIOUS!

LOOK AT "ALL" OF YOUR FUSES

MR. STARTER COULD BE BAD

TURN YOUR HIGH BEAMS ON---ATTEMPT A START----DO THE LIGHTS DIM TO NOTHING?

BEST PART HERE---READ MY ANSWER IN THIS LINK

http://www.2carpros.com/questions/1996-chevrolet-tahoe-wont-start-sounds-dead-battery-jumpbox-get-same-reults

KEEP US POSTED

THE MEDIC

Tiny

armando123456

October, 19, 2012 AT 5:30 AM

I will try to check all fuses and go threw all connections tomorrow as im off, didnt try the high beam thing because I have zero electrical power lights wont dim because they wont even turn on. Basically is acting like I have no battery connected at all. Thanks for the advise

Please login or register to post a reply.

Battery Replacement
Battery Replacement Ford Escape 2000-2006
Battery Replacement Honda Civic 2006-2011
Battery Replacement Ford Contour 1996-2000
Battery Replacement Guide