ELECTRICAL PROBLEM?

2001 Infiniti I30

Tiny

DKoz

September, 20, 2012 AT 6:33 PM

Made some progress. Disconnected harness from front speaker amp and now getting power for radio. Will get new speakers for the doors and rewire. But horn circuit is still hot on both sides. And still no instrument cluster lights.

Tiny

KHLow2008

September, 20, 2012 AT 7:32 PM

Have you done the test for cluster light as per my reply to your other post?

Let us keep all correspondence over here so we don't get mixed up.

Are the taillights working?

You definitely have a short to power and it might be at the fusebox.
Disconnecting the speakers from amp could mean the speakers are shorting out their circuit due to bad wires or they are shorted to ground.

Tiny

DKoz

September, 20, 2012 AT 8:54 PM

Sorry. Replied to other post. Both red/yellow and red/white have power/voltage. Taillights working. Still no illumination. Will check switch now. The one on the dash. And again thank you. Will donate in the future. Just rough right now

Tiny

KHLow2008

September, 20, 2012 AT 10:23 PM

Perform the test as per previous post on the wires for the lighting system at radio. You can disconnect the radio connector and turn on lights to see if it works for the dash illumination.

Tiny

DKoz

September, 20, 2012 AT 10:56 PM

Yeah. We got it. Everything works now #1 mini fuse at j/b was good but I cleaned it out with spray and reinserted the fuse. All works. Sorry for your time but really helped jump start my brain with your suggestions.I hope I never have to ask a question again. Yea right. Thank You. Dave

Tiny

KHLow2008

September, 20, 2012 AT 11:32 PM

Glad to know problem has been resolved.

Please login or register to post a reply.

Instrument Cluster Replacement GMC Yukon
Cabin Air Filter Replacement
Open Hood Video
Blend Door Actuator Replacement
Dynamat Door Installation