My truck had a aftermarket alarm system, that.

Tiny
RAVERILL
  • MEMBER
  • 2001 DODGE RAM
  • 144,000 MILES
My truck had a aftermarket alarm system, that was partialy uninstalled, but there was
2 relays under the dash was offroading when relays fell from under dash a wire came off
when this happend and shorted out the pcm causeing it to catch on fire and melted the
first plug closest to the fender well. I since then got another plug exactly the same from the
junk yard. Resoildered it in directly with heat shrink. Seems to be fine, got a used pcm. Which
seems to be fine excecpt now when I try and start it I get a p1491 code a 0340 code and
a 1698 code. I did also replace the hall effects sensor with a new one. And cut out the last
existing relays and misc. Alarm systems components. It acts like it wants to start. But doesnt
seem like the electrical is staying on the way it is suppose to. I am getting intermintent spark
seems kinda weak, new plugs, coil, plug wires, etc. Any ideas, please help.
Do you
have the same problem?
Yes
No
Thursday, December 20th, 2012 AT 7:38 AM

1 Reply

Tiny
HMAC300
  • EXPERT
Are you sure this is the right computer? 1698 is for a diesel and means no bus connection or eprom in computer not working.0340 is no cam sensor code so that may be why you aren't getting apark or itnermittent. And was the computer the same that came out of the truck i.E. Engine/transetc. You my have to check the cam sensor wiring or wiring to pcm, but good luck on this one.
Was this
answer
helpful?
Yes
No
Thursday, December 20th, 2012 AT 2:15 PM

Please login or register to post a reply.

Recommended Guides