MY 2001 DODGE DAKOTA SEEMS TO BE MISSING IN A ...

2001 Dodge Dakota

Tiny

reverend1735

October, 17, 2012 AT 5:36 PM

My 2001 dodge dakota seems to be missing in a way and it seems to have a hard time starting every now and again. It's also using antifreeze. Can these ba linked? Or could it be due to a camshaft sensor being bad?

FOUND 1645 RELATED QUESTIONS

Cam Sensor

72 ANSWERS
2 IMAGES

3 Answers

Tiny

JDL

October, 17, 2012 AT 5:44 PM

Any applicable trouble codes? How long since a tune-up? Use a gage and check fuel pressure. With hard starting, have helper crank it, while you visually check for spark at the plugs. If spark everywhere, check injector pulse.

Tiny

reverend1735

October, 17, 2012 AT 7:39 PM

It is actually showing 3 codes.
1: camshaft position sensor A circuit.
2: power steering pressure sensor switch circuit
3: small emissions leak at the evap.
It's been probably 4 to 5 years since my last tune up The fuel pressure seems good; I don't have a gauge to check it with but I checked it at the valve at the engine, and there's plenty of pressure. All fluids have been changed. It's just the hard starting and it's using engine coolant, but I really haven't noticed any leaks at or around the radiator.

Tiny

JDL

October, 18, 2012 AT 2:56 PM

The computer has to see the cam and crank sensor signal or it won't start. An intermittent issue can be hard to track down.

Please login or register to post a reply.

How to read codes Chevrolet Blazer
Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear Scion XD
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear Mercedes-Benz C230
Code Read Retrieval/Clear Honda Civic
Camshaft Angle Sensor Replacement P0015