Ford Focus stumbles under load

Tiny
ADRENALINE321
  • MEMBER
  • 2000 FORD FOCUS
  • 4 CYL
  • FWD
  • MANUAL
  • 150 MILES
Got a 2000 Focus, 2.0 zetec engine stumbles/hesitates under acceleration/load. Idles ok and I can rev up the motor just fine when not in gear. Replaced the dpfe sensor, spark plugs & plug wires. No improvement. What is the culprit? I have read a lot of forums where people had the same symptoms as mine and it was the dpfe sensor for the EGR. I have also checked for vacuum leaks using propane gas around the intake and vacuum hoses with no change in the idle. Please help!
Do you
have the same problem?
Yes
No
Thursday, August 4th, 2011 AT 1:22 AM

3 Replies

Tiny
ASEMASTER6371
  • EXPERT
I would check the fuel pressure. If it is ok, then you may have a clogged injector.

Roy
Was this
answer
helpful?
Yes
No
Thursday, August 4th, 2011 AT 1:49 AM
Tiny
MNTHNY4
  • EXPERT
DID YOU CHANGE THE COIL PACK
Was this
answer
helpful?
Yes
No
+1
Wednesday, October 12th, 2011 AT 12:55 PM
Tiny
ADRENALINE321
  • MEMBER
Thanks for the suggestion on the coil pack. I did replace it a few days after my original post. I took off the coil pack and had it tested at Autozone with a multimeter and they said there was nothing wrong with it, but after thinking about it, all they can test for is if you have continuity in the coil. They can't test for performance under load. So I replaced it despite their "professional" advice to look elsewhere. Guess what Autozone, the coil pack was bad.
Car runs like a top now.
Was this
answer
helpful?
Yes
No
+2
Wednesday, October 12th, 2011 AT 5:29 PM

Please login or register to post a reply.

Recommended Guides