STUMBLES UNDER LOAD

2000 Ford Focus

Tiny

adrenaline321

August, 4, 2011 AT 1:22 AM

Got a 2000 Focus, 2.0 zetec engine stumbles/hesitates under acceleration/load. Idles ok and I can rev up the motor just fine when not in gear. Replaced the dpfe sensor, spark plugs & plug wires. No improvement. What is the culprit? I have read a lot of forums where people had the same symptoms as mine and it was the dpfe sensor for the EGR. I have also checked for vacuum leaks using propane gas around the intake and vacuum hoses with no change in the idle. Please help!

FOUND 2910 RELATED QUESTIONS

3 Answers

Tiny

ASEMaster6371

August, 4, 2011 AT 1:49 AM

I would check the fuel pressure. If it is ok, then you may have a clogged injector.

Roy

Tiny

mnthny4

October, 12, 2011 AT 12:55 PM

DID YOU CHANGE THE COIL PACK

Tiny

adrenaline321

October, 12, 2011 AT 5:29 PM

Thanks for the suggestion on the coil pack. I did replace it a few days after my original post. I took off the coil pack and had it tested at Autozone with a multimeter and they said there was nothing wrong with it, but after thinking about it, all they can test for is if you have continuity in the coil. They can't test for performance under load. So I replaced it despite their "professional" advice to look elsewhere. Guess what Autozone, the coil pack was bad.
Car runs like a top now.

Please login or register to post a reply.

Vacuum Leak Test and Repair - All Cars
Mass Air Flow Sensor Clean Toyota Tacoma
Mass Air Flow Sensor Clean Ford Explorer 1995
Easily Clean Your Throttle Bore Like a Pro