Fault Indicators

Tiny
MATT MILICIC
  • MEMBER
  • 2000 DODGE RAM
  • V8
  • 4WD
  • AUTOMATIC
  • 55,860 MILES
I have a Dodge Ram 2500 with the 5.9L V8. I recently replaced the PCM and both the camshaft and crankshaft sensors. The truck starts and runs but I still see a "no bus" meggase on the odometer and my code reader shows no codes but 3 of the monitors show as INC. How long do I have to run or drive the truck to get these monitors ready and what is the most likely cause of the "no bus" message?
Do you
have the same problem?
Yes
No
Friday, January 7th, 2011 AT 6:33 PM

5 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
The no bus indicates there is no communication between the computer and its components. You need to check wiring between the PCM and problem area. If you reciently replaced the PCM, make sure none of the pins in the wiring harness plug pushed in and are no longer making contact.
Was this
answer
helpful?
Yes
No
Wednesday, January 12th, 2011 AT 9:40 PM
Tiny
MATT MILICIC
  • MEMBER
I double checked all of the connectors on the PCM and in the power distribution module but found nothing. As I do not know what the problem is I am at a loss to know where to go next. I have a OBD II code reader but it says there are 0 codes. I know this code reader only covers codes from P0001 to P0998 so if there are manufacturer codes present I cannot see them.
Was this
answer
helpful?
Yes
No
Sunday, January 16th, 2011 AT 6:04 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
I hate to say it, but you may need to get a different scanner or have it checked by one who does. As I mentioned, the no bus indicates there is a break down of communication between the computer and components.
Was this
answer
helpful?
Yes
No
Sunday, January 16th, 2011 AT 6:36 PM
Tiny
MATT MILICIC
  • MEMBER
I will be picking up a different Scanner tonight and performing the testing over the weekend. I will post any and all codes I find as soon as I have them.
Was this
answer
helpful?
Yes
No
Friday, January 21st, 2011 AT 5:51 PM
Tiny
MATT MILICIC
  • MEMBER
I got a better code scanner from Autozone's loaner program but it showed 0 codes just like the pocket scanner I have did. I still have the "No Bus" message on the odometer. I guess I need to know what the potential causes are for that message and rule them out 1 at a time. Can you provide a list of the potential causes?
Was this
answer
helpful?
Yes
No
Sunday, January 23rd, 2011 AT 4:00 PM

Please login or register to post a reply.

Recommended Guides