WHY DOES THE ENGINE MISS ON COLD STARTUP,AND NOT WHEN AT OPERATING TEMPERATURE?

2000 Chevrolet Blazer

Tiny

robertd55

September, 5, 2012 AT 11:58 PM

2000 blazer 4x4 has new tuneup, new TPS, new IAC, new MAP sensor, checked EGR valve for carbon buildup, very little and function. Did not check for electrical, though. It was in closed position and seated when I pulled it. On cold startup in morning, starts fine, idles fine, idles down fine, when I start driving it, it has a severe miss until it reachs operating temperature. It runs fine after reaching peak operating temperature. It is now 78degrees in morning and 100degrees in the afternoon. Hope you can make some sense of this, and give me some solutions. Thanks, Robert

FOUND 1062 RELATED QUESTIONS

7 Answers

Tiny

ASEMaster6371

September, 6, 2012 AT 12:14 AM

Could be injectors needing service. Could be carbon on the intake valves.

Did you replace the wires and cap and rotor?

Roy

Tiny

robertd55

September, 6, 2012 AT 1:54 AM

Yes and this missing did not start till 3000m later.

Tiny

ASEMaster6371

September, 6, 2012 AT 1:55 AM

Have the injectors professionally cleaned. Gas tank additives have little or no effect.

Roy

Tiny

robertd55

September, 6, 2012 AT 2:07 AM

Since Ive had the vehicle Ive always added Lucas or something similar to tank. Thanks, Robert

Tiny

ASEMaster6371

September, 6, 2012 AT 3:09 AM

Not good enough. Theyy need to be direct injection cleaned.

Roy

Tiny

robertd55

September, 6, 2012 AT 3:56 PM

Then, why would it not miss all the time, after it warms up also?

Tiny

robertd55

September, 6, 2012 AT 5:55 PM

If it had a dirty injecter would it not miss all the time?

Please login or register to post a reply.

Code Read Retrieval/Clear Mercedes-Benz C230
How to read codes Chevrolet Blazer
Code Read Retrieval/Clear Scion XD
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear - Dodge Stratus
Code Read Retrieval/Clear Mercedes Benz
Code Read Retrieval/Clear