I changed the tranny fluid temperature sensor and light still comes up. Whats wrong?

Tiny
REILLYFAMILY
  • MEMBER
  • 1999 SATURN SL2
  • 122,000 MILES
I put a newer transmission on my 99 saturn and the transmission fluid temp sensor code came up I changed sensor light still on. Car is running great and the transmission is working but warning light for the sensor still on even though its changed. What can it be?

Thanks for the help!
Do you
have the same problem?
Yes
No
Friday, October 28th, 2011 AT 5:56 PM

9 Replies

Tiny
SATURNTECH9
  • EXPERT
I need to know what the exact code number is?It will be P and a four digit number.
Was this
answer
helpful?
Yes
No
Sunday, October 30th, 2011 AT 2:58 AM
Tiny
REILLYFAMILY
  • MEMBER
The code is po 713 and I was told I need the the sensor from the GM parts deparment since those sensors all look the same on the saturn. I will go tomorrow to GM and get a new one thats correct. I hope this solves the problem. Your advise will help thanks.
Was this
answer
helpful?
Yes
No
Sunday, October 30th, 2011 AT 11:47 PM
Tiny
SATURNTECH9
  • EXPERT
So did you change the small little sensor by the transmission filter?Those sensor hardly ever go bad its usually a connector issue. Are you sure the wire or connector isnt damaged?That sensor is the same as the coolant temp sensor one you can get one at auto zone.
Was this
answer
helpful?
Yes
No
Monday, October 31st, 2011 AT 12:19 AM
Tiny
REILLYFAMILY
  • MEMBER
We are getting new connector and sensor today at GM parts so hopefully that will solve the problem. I will keep you posted. Car still running good with no issues.
Was this
answer
helpful?
Yes
No
Monday, October 31st, 2011 AT 11:38 AM
Tiny
SATURNTECH9
  • EXPERT
I havent seen a reason to have to get a gm factory part for that sensor the aftermarket ones work just fine. But keep me posted on what you fine.
Was this
answer
helpful?
Yes
No
Monday, October 31st, 2011 AT 11:42 AM
Tiny
REILLYFAMILY
  • MEMBER
Hi also yes we did but dont know if we got the right one that is why we are getting one from GM to make sure. Thanks and will keep you posted.
Was this
answer
helpful?
Yes
No
Monday, October 31st, 2011 AT 1:31 PM
Tiny
SATURNTECH9
  • EXPERT
Alright keep me posted.
Was this
answer
helpful?
Yes
No
Monday, October 31st, 2011 AT 1:38 PM
Tiny
REILLYFAMILY
  • MEMBER
Hi my mechanic changed the sensor and connector and light is off now. My son drove it to school today and it works great! God willing the light will stay off. Thanks
Was this
answer
helpful?
Yes
No
Tuesday, November 1st, 2011 AT 11:33 PM
Tiny
SATURNTECH9
  • EXPERT
Your welcome had a feeling the connector was bad.
Was this
answer
helpful?
Yes
No
Wednesday, November 2nd, 2011 AT 4:06 AM

Please login or register to post a reply.

Recommended Guides