Engine bucking and lurching

Tiny
TNMAN6978ZH
  • MEMBER
  • 1999 SATURN SL1
  • 4 CYL
  • MANUAL
  • 265,000 MILES
1999 Saturn SL1. When accelerating, engine bucks and lurches, loses power. What could it be? Thanks! When I take my foor off of accelerator, it idles fine. When shifting, engine stays at high idle, then falls slowly.
Do you
have the same problem?
Yes
No
Monday, May 30th, 2011 AT 9:19 PM

3 Replies

Tiny
SATURNTECH9
  • EXPERT
Do you have any codes?If you haven't checked you need to do that. Does is buck or lurch worse with the a/c on if the a/c works?Have checked the plugs and wire's?Also if the coil towers are corroded?What kind of spark plugs do you have?
Was this
answer
helpful?
Yes
No
Monday, May 30th, 2011 AT 9:32 PM
Tiny
TNMAN6978ZH
  • MEMBER
No difference if the a/c is on or off. Haven't had codes checked lately. Also, it doesn't do it all the time. Sometimes I start it up and it accelerated fine. Other times it lurches and****** and bucks the whole time I'm accelerating. Plugs and wires are new. AC plugs, I think. Thanks!
Was this
answer
helpful?
Yes
No
Monday, May 30th, 2011 AT 9:40 PM
Tiny
SATURNTECH9
  • EXPERT
You didn't put platnuim plugs in the engine did you?Also did you double check to make sure you don't have any crossed spark plug wire's?How long ago did you replace the fuel filter?There supposed to be changed every 100,000 miles by then there pretty clogged up. The filter also has the fuel pressure regulator built into it.I would also check the coolant temp sensor and see if the connector is corroded pretty common on that car. The coolant temp sensors fail often on those cars and cause all kinds of symptoms including surging lurching etc like your having.
Was this
answer
helpful?
Yes
No
+1
Monday, May 30th, 2011 AT 10:42 PM

Please login or register to post a reply.

Sponsored links