Misses when I give it gas and engine light is on

Tiny
KARA88
  • 1999 PONTIAC GRAND PRIX
  • 162,000 MILES

I have replaced egnition module coil pack, cam sensor, crank shaft sensor, and last Ithe throttle position sensor. It misses bad when im driving and even misses when it idels and reving. Idk what it could be. The engine will stay. On for months at a time then suddenly go off and the car will run great. No misses or anything. Then it will come back on if u go to to pass someone and it will flash a gew. Times then start running like crap again. Can u help me or no.

Do you
have the same problem?
Yes
No
Thursday, January 5th, 2012 AT 8:56 PM

4 Replies

Tiny
DOCFIXIT
  • EXPERT
  • 18,988 POSTS

Have codes been read for engine light being on? If yes what were they?

Was this
answer
helpful?
Yes
No
Thursday, January 5th, 2012 AT 9:01 PM
Tiny
KARA88
  • MEMBER

I havent been able to read any codes cause the thing where u hook a machine up wont let anything read it. Idk if theres a fuse blowed. To it or if the whole car is messed up. Im gonna try a map sensor today.

Was this
answer
helpful?
Yes
No
Thursday, January 5th, 2012 AT 9:13 PM
Tiny
DOCFIXIT
  • EXPERT
  • 18,988 POSTS

You can keep throwing parts at car and maybe fix or go to ASE Cert shop find out what is problem. Already spent plenty$$$ with no results

Was this
answer
helpful?
Yes
No
Thursday, January 5th, 2012 AT 9:20 PM
Tiny
CHERYLR736
  • MEMBER

Kara88 sounds like a clogged fuel injector

Was this
answer
helpful?
Yes
No
Thursday, March 22nd, 2012 AT 3:00 AM

Please login or register to post a reply.

Other Check Engine Soon Light Questions