1999 Jeep Wrangler Auto Transmission

Tiny
MACSTAGGS
  • MEMBER
  • 1999 JEEP WRANGLER
  • 4.0L
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 150,000 MILES
The tranny slips going into low until the fluid gets some warmth. After it warms up, no slip at all, even starting it up after sitting an hour+. No problems till now. I wonder if it is rebuild time or maybe a neutral switch that may need replacing. Is there a neutral switch that works off the brake peddle? Till the fluid gets up to temperature, when I push on the brake peddle at a stop light, it feel like the trans goes in & out of low. Like I said, once the temp is at normal operation, goes into low and shifts up great.
Do you
have the same problem?
Yes
No
Saturday, August 30th, 2014 AT 6:25 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Is the fluid clean and full? Has the check engine light come on?
Was this
answer
helpful?
Yes
No
Saturday, August 30th, 2014 AT 7:28 PM
Tiny
MACSTAGGS
  • MEMBER
Yes, the fluid is full and clean. No check engine light. I don't know but I was told the 1999's didn't have the computer diagnostics the newer ones have.
Was this
answer
helpful?
Yes
No
Saturday, August 30th, 2014 AT 8:15 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
1995 was the change over to OBD2. It has one. Also, the neutral safety switch has nothing to do with this. The only thing I can think of at this point is to check pump pressure. It may be weak when cold.
Was this
answer
helpful?
Yes
No
Monday, September 1st, 2014 AT 7:25 PM

Please login or register to post a reply.

Recommended Guides