1999 Buick Regal Cooling fans

Tiny
TCOB
  • MEMBER
  • 1999 BUICK REGAL
  • 3.8L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 140,000 MILES
They do not come on at all, even when turning AC on that does not come on either.I have checked all fuses and relays they are good.I discounted fan motors plug and supplied jumper wires to fan side of plug they work. No power is coming to fans.I changed temp sensor and still the same no fans or AC working. There is a coolant level sensor on radiator but I do not think it is the problem either it is working as it should. Could my problem be tied in with AC not working also?Please help as I am not sure what to check next
Do you
have the same problem?
Yes
No
Friday, May 30th, 2014 AT 9:15 AM

12 Replies

Tiny
HMAC300
  • EXPERT
Check to see if relays are getting a signal from pcm it may be a fuse box problem and or wiggle one or two of the relays tosee if fans kick on. If they tweak the relay progs a tad tosee if they will make better connection.
Was this
answer
helpful?
Yes
No
-1
Friday, May 30th, 2014 AT 9:30 AM
Tiny
TCOB
  • MEMBER
Are the dark green and dark blue wires coming from pcm to relays?Do I check for power or ground? When I checked relays earlier I checked for power only.
Was this
answer
helpful?
Yes
No
Friday, May 30th, 2014 AT 11:09 AM
Tiny
HMAC300
  • EXPERT
The pcm controls these so put the ac on an doi'm not sure which relay will work if the car isn't hot the low may come on for sure but it could be high so check them both. Like I said it may be a fuse box connection that is causing this as well so if you get power tweak the prongs a tad. Maybe use some dielectric compound as well on them for better contact as sometimes they get corrosion on them.
Was this
answer
helpful?
Yes
No
Friday, May 30th, 2014 AT 12:12 PM
Tiny
TCOB
  • MEMBER
I will check like you said. What type signal from pcm, is it power to relays or does pcm control ground and is it those 2 wires you talked about earlier? I will check fuse box wiring and wiggle test relays and wires before anything else?
Was this
answer
helpful?
Yes
No
Friday, May 30th, 2014 AT 4:40 PM
Tiny
HMAC300
  • EXPERT
It should be a power signal to activate the relay and yes wiggle test the relays.
Was this
answer
helpful?
Yes
No
Saturday, May 31st, 2014 AT 5:58 AM
Tiny
TCOB
  • MEMBER
Ok did that #9, 10 and 12 relays all have power, checked for corrosion none checked for loose or damaged wires good. Did wiggle test no changes. With relays in place slightly raised tested with a test light and first fan drivers side will come on high I think. It will come on with relay out to when using test light. The test light will light up a little bit while doing test when fan starts to and during fan op test.
Was this
answer
helpful?
Yes
No
Monday, June 2nd, 2014 AT 9:47 AM
Tiny
HMAC300
  • EXPERT
It sounds like the relay s are good just not making good contact. Put somedielectric grease on prongs an dpush down as far as you can. It may be a fuse box problem wher ethe wires contacts have sliped down a little and not sure if they can be pushed up far enough or not. If this has bolts in fuse box tighten them to about 9nm no higher as it will strip them.
Was this
answer
helpful?
Yes
No
Monday, June 2nd, 2014 AT 9:50 AM
Tiny
TCOB
  • MEMBER
Well I tried that. Outside of taking fuse box apart to get to terminals and crimping them to make a snug fit. Not sure if box is meant to be serviceable.
Was this
answer
helpful?
Yes
No
Monday, June 2nd, 2014 AT 10:55 AM
Tiny
HMAC300
  • EXPERT
It's really not serviceable but I fyou have to you do try pushing them back in farther from behind make battery is disconnected too
Was this
answer
helpful?
Yes
No
Monday, June 2nd, 2014 AT 12:04 PM
Tiny
TCOB
  • MEMBER
Yes I tried that they do go in some. I am having a hard time believing that just not enough solid evidence. I have tried every thing you said nothing made them come on. The first relay is a 4prng bottom 2 have power 2nd relay is a 5prng lower left one has power last one is a 4prng top 2 have power first 2 I can test light them first fan comes on does not mater if car is hot or not or AC is on or not
Was this
answer
helpful?
Yes
No
Monday, June 2nd, 2014 AT 2:31 PM
Tiny
HMAC300
  • EXPERT
See if you can spread the prongs a little or the tabs that they go inot otherwise I dont' know what to tell you.
Was this
answer
helpful?
Yes
No
Monday, June 2nd, 2014 AT 3:37 PM
Tiny
TCOB
  • MEMBER
OK. Thank you for your time and help.I will use what gave and continue on.
Was this
answer
helpful?
Yes
No
Monday, June 2nd, 2014 AT 5:23 PM

Please login or register to post a reply.

Recommended Guides