Why does my engine light come on after replacing.

Tiny
TERRIWILLIAMS
  • 1998 PONTIAC SUNFIRE
  • 226,332 MILES

Why does my engine light come on after replacing temperature sensor? Replaced the sensor because my temp guage kept going up & down, worked fine for a couple days then engine light came on

Do you
have the same problem?
Yes
No
Thursday, February 14th, 2013 AT 7:32 AM

5 Replies

Tiny
HMAC300
  • EXPERT
  • 45,761 POSTS

Scan for codes it may be something else

Was this
answer
helpful?
Yes
No
Thursday, February 14th, 2013 AT 3:12 PM
Tiny
TERRIWILLIAMS
  • MEMBER

Did that said it was my temp sensor they cleard it ran fine for a little while now engine light on again & gauge not working right

Was this
answer
helpful?
Yes
No
Thursday, February 14th, 2013 AT 10:05 PM
Tiny
HMAC300
  • EXPERT
  • 45,761 POSTS

Then have it checked for a shorted wire or have apro look at it to see what is wrong

Was this
answer
helpful?
Yes
No
Thursday, February 14th, 2013 AT 10:16 PM
Tiny
TERRIWILLIAMS
  • MEMBER

Thought you were a pro should of had a pro look at instead of wasting my time with a pro?

Was this
answer
helpful?
Yes
No
Saturday, February 16th, 2013 AT 8:10 PM
Tiny
HMAC300
  • EXPERT
  • 45,761 POSTS

Look it pal there is a bunch of things that can be wrong I can't check shorted wires or resistance in sensors to see if they are good or not. If the sensor was from china hard telling whether it worked or not. You rgauges aren't working right per YOU as your dash is digitally operated it can be a bad dash that is why I sen tyou to a pro I cna't do that over the computer. We give the best advice we can

Was this
answer
helpful?
Yes
No
Saturday, February 16th, 2013 AT 8:43 PM

Please login or register to post a reply.

Other Instrument Cluster Gauge Engine Temperature Replace/Remove Questions