98 Sunfire linking error

Tiny
J.STIEG
  • MEMBER
  • 1998 PONTIAC SUNFIRE
  • 170,000 MILES
Working on a sunfire and the check engine light is on, but when I go to scan it I get linking error. How do I fix that?
Do you
have the same problem?
Yes
No
Thursday, August 25th, 2011 AT 3:10 AM

15 Replies

Tiny
FACTORYJACK
  • EXPERT
It may be a problem with the scan tool you are using, and not necessarily with the vehicle. Before getting too heavily involved in assuming there is a problem with the vehicle, try another scan tool, or even a code reader. Pin 9, the tan wire at the data link connector, is the scan tool communication line for the PCM, EBCM, SDM, and the IPC for UART communications. Pin 2, purple wire, is class 2 to PCM only. Do you have a scanner that can access other modules, and does it communicate with them?
Was this
answer
helpful?
Yes
No
Thursday, August 25th, 2011 AT 4:46 AM
Tiny
DANLESABRE
  • MEMBER
Does the car start? How are the fuses?
Was this
answer
helpful?
Yes
No
Thursday, August 25th, 2011 AT 4:58 AM
Tiny
J.STIEG
  • MEMBER
I just bought the car in a non running condition and wired up the pcm wire harness, I replaced the blown PCM fuse as well. Car runs now just says linking error, and check engine light is on. I will check my reader to see what pins it uses. I would like to get one that read body codes.
Was this
answer
helpful?
Yes
No
Friday, August 26th, 2011 AT 1:08 AM
Tiny
FACTORYJACK
  • EXPERT
Since the wiring had to be repaired, and the fuse was blown, it may have a problem that goes beyond normal diagnosis with factory information. The first thing to do is to see if another tool can communicate. If it does not, then you have a basis to start your diagnosis.
Was this
answer
helpful?
Yes
No
Friday, August 26th, 2011 AT 2:09 AM
Tiny
J.STIEG
  • MEMBER
My reader will work on all my other vehicles. It does not have pin #9, I think it uses #2, It will only pull P codes. #16 has batt voltage.
Was this
answer
helpful?
Yes
No
Friday, August 26th, 2011 AT 2:13 PM
Tiny
FACTORYJACK
  • EXPERT
Since the vehicle starts and runs, the PCM is functional. Check the continuity of pin 2 to pin 59 of C1(blue) at PCM. Also check the terminal tension of pin #2 at DLC.
Was this
answer
helpful?
Yes
No
Friday, August 26th, 2011 AT 2:33 PM
Tiny
J.STIEG
  • MEMBER
I checked the pin#2 wire from the DLC going to the pcm, and at the PCM there was two purple wires so I switched them around and attached to #59 at PCM. I get codes now but I think there s problems at the PCM yet with the wiring.

Can you tell me what the pin# at PCM for the map sens +5 volt gray wire. Thanks
Was this
answer
helpful?
Yes
No
Friday, August 26th, 2011 AT 8:40 PM
Tiny
FACTORYJACK
  • EXPERT
Yes, the 5 volt reference gray wire for both engine variants is at PCM pin 35 of connector C2, the clear body connector.
Was this
answer
helpful?
Yes
No
Friday, August 26th, 2011 AT 9:18 PM
Tiny
J.STIEG
  • MEMBER
One last thing, trying to sort out the gray +5v wires to the PCM. I think there all backwards. Can you tell me the C2 PCM pin wiring for the following sensors, they are all gray +5v wires.
"camshaft sensor gray+5v"
"AC pressure sensor gray +5v"
"EGR gray+5v"
"IATS" need PCM pin# for these four. Thanks!
Was this
answer
helpful?
Yes
No
Friday, August 26th, 2011 AT 11:26 PM
Tiny
FACTORYJACK
  • EXPERT
How's this?
Was this
answer
helpful?
Yes
No
Saturday, August 27th, 2011 AT 5:05 AM
Tiny
J.STIEG
  • MEMBER
Perfect, thanks
Was this
answer
helpful?
Yes
No
Saturday, August 27th, 2011 AT 5:23 AM
Tiny
J.STIEG
  • MEMBER
I got all of the wiring issues taken care of.
Now it says "CKP sensor variation not learned", any ideas on how to reset that? Thanks
Was this
answer
helpful?
Yes
No
Tuesday, August 30th, 2011 AT 2:39 AM
Tiny
FACTORYJACK
  • EXPERT
Is your diagnostic tool just a code reader, or does it read data and perform functions? If it has a special function menu, there should be a crankshaft variation relearn feature. As far as I know, there is no other way to perform this other than with a scan tool.
Was this
answer
helpful?
Yes
No
Tuesday, August 30th, 2011 AT 2:57 AM
Tiny
J.STIEG
  • MEMBER
I got the crank sensor issue taken care of. I noticed my speedometer is not working, can you get me a wiring diagram for that as well "vehicle speed sensor". Thanks
Was this
answer
helpful?
Yes
No
Tuesday, August 30th, 2011 AT 6:16 PM
Tiny
FACTORYJACK
  • EXPERT
Here it is.
Was this
answer
helpful?
Yes
No
Tuesday, August 30th, 2011 AT 8:13 PM

Please login or register to post a reply.

Recommended Guides