IM ONLY RUNNING OFF 2 CYL, DONT KNOW WHY

1998 Mitsubishi Eclipse

Tiny

mud4594

February, 13, 2011 AT 6:02 AM

I have a 98 eclipse spyder gs 4cyl 2.4 l engine. I'm only running off of 2 cylinders and don't know why. I have replaced the ingition coil, fixed and checked the wiring harness, and tried a new ecm. The only thing I havent tried is the crankshaft postion sensor and the camshaft position sensor. Isone of these goin to fix my problem. Im at a total loss

FOUND 335 RELATED QUESTIONS

6 Answers

Tiny

mhpautos

February, 13, 2011 AT 6:16 AM

Check leads, plugs and injection at those cylinders, which cylinders are not firing?

Mark (mhpautos)

Tiny

rasmataz

February, 13, 2011 AT 6:24 AM

The crankshaft position sensor tells the computer which cylinders to fire-

Tiny

mhpautos

February, 13, 2011 AT 6:27 AM

If the CPI sensor is faulty you will not get a signal at all, and that is also for a cam sensor, there will not work on selected cylinders to give you this type of problem.

Markk (mhpautos)

Tiny

mud4594

February, 13, 2011 AT 6:43 AM

Ive checked the plugs and injectors, 2 and 3 arent firing at all. Thats what I thought about the sensors, they would not fire at all. Im at a total loss here, any new input?

Tiny

mud4594

February, 13, 2011 AT 6:44 AM

Of course im down to go buy both damnsnesors and see if anyhting changes, just for the sake of trying everything

Tiny

rasmataz

February, 13, 2011 AT 7:10 AM

Ive checked the plugs and injectors, 2 and 3 arent firing at all.

Check and test the computer ground drivers for the injectors

Please login or register to post a reply.

Read Codes Like a Pro
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear
How to read codes Chevrolet Blazer
Code Read Retrieval/Clear - Dodge Stratus
Code Read Retrieval/Clear Scion XD
How to gather codes Ford Explorer