1998 Dodge Ram crankshaft sensor

Tiny
SONNYTHOMPSON
  • MEMBER
  • 1998 DODGE RAM
  • 162,000 MILES
When driving a while engine will no start, dianosed bad crankshaft sensor, won t start when warm, after cooling starts again and dianosed bad sensor not detected. Installed new sensor still doing the same thing
Do you
have the same problem?
Yes
No
Tuesday, June 4th, 2013 AT 5:02 PM

8 Replies

Tiny
HMAC300
  • EXPERT
Rescan for codes and check fuel pressure first. Should be 44-54 psi
Was this
answer
helpful?
Yes
No
Wednesday, June 5th, 2013 AT 6:33 AM
Tiny
SONNYTHOMPSON
  • MEMBER
Scanned first said bad crankshaft sensor, I replaced it and the same problem when warm won t start scan reads bad sensor, when cool restarts no scan codes
Was this
answer
helpful?
Yes
No
Wednesday, June 5th, 2013 AT 7:22 AM
Tiny
SONNYTHOMPSON
  • MEMBER
Fuel pressure ok no spark when this happens
Was this
answer
helpful?
Yes
No
Wednesday, June 5th, 2013 AT 7:33 AM
Tiny
HMAC300
  • EXPERT
If you can do a wiggle test on cranks sensor wires, the connection may be bad on that. It can also be a bad connection at pcm. Also replace asd relay with a like one and see if that helps.
Was this
answer
helpful?
Yes
No
Wednesday, June 5th, 2013 AT 9:41 AM
Tiny
SONNYTHOMPSON
  • MEMBER
Now I get code P3040 camshaft sensor and can t find one
Was this
answer
helpful?
Yes
No
Monday, June 10th, 2013 AT 11:30 AM
Tiny
HMAC300
  • EXPERT
It's inside distributor
Was this
answer
helpful?
Yes
No
Monday, June 10th, 2013 AT 5:21 PM
Tiny
SONNYTHOMPSON
  • MEMBER
DIST COIL SWITCH IN DISTRIBUTOR WAS THE PROBLEM THANKS MUCH
Was this
answer
helpful?
Yes
No
Friday, June 14th, 2013 AT 9:47 AM
Tiny
HMAC300
  • EXPERT
That is the camshaft sensor glad you got it fixed.
Was this
answer
helpful?
Yes
No
Friday, June 14th, 2013 AT 9:58 AM

Please login or register to post a reply.

Recommended Guides