Pontiac Problem

Tiny
GIMMEWHATEVER
  • MEMBER
  • 1997 PONTIAC GRAND PRIX
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 89,000 MILES
Hi I have a 1997 Pontiac Grand Prix GT. I put a little less than 30,000 miles on it since I bought it in 2002. But when I first bought it the transmission went a few days after so the dealer rebuilt the tranny. After that it sat for 3 years. And now that I got it running 2 years ago Ive been having a problem. When Im on the highway or high speed limit road around 40mph the rpms drop to 2000 to 2500 and will just stay there until I floor the gas pedal or let off then back on the gas. Once I do that the rpms go back up and its fine but itll continue doing that from 40 mph and up. I replaced spark plugs and wires, alternator, belts and I had the transmission fluid flushed. I would really appreciate it if you could give me some insight on what it could be as I am not able to afford a new car and this is my only means of transportation. Thank you very much for your time and whatever answer you can give me.
Do you
have the same problem?
Yes
No
Wednesday, December 15th, 2010 AT 2:11 AM

6 Replies

Tiny
DAVE'S BIG BACKYARD!
  • EXPERT
All you can do is have it scaned and go from there, but if I was to quess I would have to say it was a bad shift solnoid. If spelled right lol.I dont think it has a kick down cable?If it does then its out of adjust.
Was this
answer
helpful?
Yes
No
Wednesday, December 15th, 2010 AT 2:29 AM
Tiny
BMRFIXIT
  • EXPERT
Let me ask if you have a check engine light on?
And if so 1st should get the codes
most local part stores and local shops will scan it for free

also you may want to check catalytic converter and exhaust back pressure

let me know
Was this
answer
helpful?
Yes
No
Wednesday, December 15th, 2010 AT 2:31 AM
Tiny
DAVE'S BIG BACKYARD!
  • EXPERT
Also thinking a lockup solnoid. And yes this would make the check eng light come on, like I said it needs to be scaned.
Was this
answer
helpful?
Yes
No
Friday, December 17th, 2010 AT 2:46 AM
Tiny
GIMMEWHATEVER
  • MEMBER
There is no check engine light on. I fixed the exhaust and it runs smoother not as loud but it didnt fix the problem. From 1mph to 40mph theres no problem. But as soon as I go above 40mph the rpms bog down to around 2000 and stay there and the higher speeds around 70 mph it bogs down to 1500rpm. I checked the vacuum and its fine I think its something inside the transmission. But then again theres no check light on. What might you suggest? I checked underneath the car and theres no real sign of any leaks. Would the transmission filter be clogged and causing this problem? And if I had a shift solenoid problem wouldnt it cause no shifting?
Was this
answer
helpful?
Yes
No
Tuesday, December 21st, 2010 AT 12:59 AM
Tiny
DAVE'S BIG BACKYARD!
  • EXPERT
Yes it might, its kind of hard to fix online, with a problem like that I would have to drive it to realy see whats going on and we both know I cant do that, sorry. It might be a running problem with the engine making it have a loss of power.
Was this
answer
helpful?
Yes
No
Friday, December 24th, 2010 AT 11:29 PM
Tiny
HMAC300
  • EXPERT
Some codes may not show up and this sounds as if the transmission is applying something thatshouldn't be. It's to late for a warranty on it but have a trans guy drive it and check it.
Was this
answer
helpful?
Yes
No
Sunday, February 13th, 2011 AT 11:25 PM

Please login or register to post a reply.

Recommended Guides