ARE MY MOTOR MOUNTS BROKE?

1997 Eagle Talon

Tiny

cstaff25

July, 18, 2012 AT 1:29 PM

I had my motor mounts changed within the past year. I had a really bad clunking problem when I shift into drive and reverse. Also some times my car shifts hard when accelerating. I was told I needed mounts so I had them replaced. The clunking didn't stop, but got a little better. So I assumed it was something else. Well yesterday I had someone shift between drive and reverse so I could watch the engine. My driverside top engine mount moved far enough it hit the frame, which is about 4 inches at least. Now maybe I am wrong, but that doesn't seem normal. Is it possible I had the mounts changed and my new ones were bad too this whole time! One of the other mounts I could see moved pretty good too, but not as bad as this top one.

5 Answers

Tiny

ASEMaster6371

July, 18, 2012 AT 1:45 PM

Are you sure that mount was changed? Does it look new?

Roy

Tiny

cstaff25

July, 18, 2012 AT 1:47 PM

I can't say for sure. It looked new and shiny when I got the car back. However, I found several chips all over that kind of bothered me at the time. By your reaction I assume I am right that that is not normal?

Tiny

ASEMaster6371

July, 18, 2012 AT 2:00 PM

Correct. I would return to the shop and show him what is going on

Roy

Tiny

cstaff25

July, 18, 2012 AT 2:01 PM

Thank you Mr. Roy for your time.

Tiny

ASEMaster6371

July, 18, 2012 AT 2:12 PM

Good luck

Please login or register to post a reply.

Engine Torque Mount Replacement
Engine Mount Replacement Chevrolet Cavalier
Engine Oil Change and Filter BMW X5
Air Filter Replacement Subaru Legacy
Engine Oil Change and Filter Chrysler PT
Air Intake Boot Replacement Toyota Tacoma
Fuel Filters Replacement 2015 RAM 2500 6.7L