HELLO I JUST HAD AN AFTER MARKET USED ...

1997 Acura CL

Tiny

dianev5055@comcast.net

November, 20, 2012 AT 3:23 AM

Hello I just had an after market used Transmission module installed 2 days ago. The car is running so much better no cutting out & bucking or engine shut off's as before. Now it has been 5 days since it was repaired & the check engine light is on again? Does this mean the module is bad or what? Do I need to pay for another diagnostic test. The Acura dealer installed it and had me sign a wavier so they are not responsible if it goes bad what would you suggest?

Please advise. I taking it to my very reputable mechanic next week. It alos needs a CV boot repair & rotars & brakes? Is this all worth it? Could the module be bad again.

Last year the came on because it would not pass emissions that problem was resolved?

FOUND 25377 RELATED QUESTIONS

Cj Stalling When Idling

33 ANSWERS
44 IMAGES

Stalling Out

43 ANSWERS
48 IMAGES

1 Answer

Tiny

ASEMaster6371

November, 20, 2012 AT 3:27 AM

Used parts are a gamble and have no warranty at all. You chose this repair instead of a new part for economic reasons, I am sure.
Yes, you are responsible for the diag again. Also, you are assuming it is the same thing but you dont know for sure. Have it checked first before jumping to conclusions.

Roy

Please login or register to post a reply.

Code Read Retrieval/Clear Scion XD
How to read codes Chevrolet Blazer
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear - Dodge Stratus
Code Read Retrieval/Clear Chevrolet Camaro