1995 Mitsubishi Mighty Max

  • 4 CYL
  • 2WD
  • 80,000 MILES
Bare with me this problem has been going on for some time I was using a tech from answerrack and I wanted to hear your opinion, I have copied the text from our discussions I would like to hear your opinion

in the beginning the truck would run sluggish, if I feathered the gas pedal, the faster it would increase speed faster but feeling held back when I pressed on the gas. This goes on for about a year.I have recently changed the plugs, wires, air filter, fuel filter, rotor and cap. One day I go to the store and I go in for about 15 minutes and come out and the truck cranks but will not start.I wait and try again about 15 minutes later. And it tries to start put sputters real bad and cuts. Then I try again and it does the same thing. After doing this several times it finally runs enough to where I can drive it like when all this started. It has happened like that about 12 times in 6 months. When I step on the gas now it will severly bog down to almost cutting off. Just on the brink of it spitting and coughing but still runs. If I let the truck idle it runs fine. If I rev it it sputters a little but then revs fine. When I put the car in drive I can drive down my path feathering it about a quarter mile and turn on the road and step on the gas and it just bogs down and stops me. Could this be a exhaust problem? Also has a new fuel pump and had the tank cleaned professionally and used several cans of sea foam over the course of 6 months. Fuel injector cleaner.I drive this truck to work and back 40 miles a day there and back total 40. Before all this happened I could feather the gas pedal to get to about 35 and then it would run a little better.I got on the highway and took 2 days to get to 65 and then if I stomped on the gas it would downshift but feel held back or bogged down. I have also heard a noise that sounded like a backfire but coming through the exhaust manifold I dunno I was driving when it has happened like 4 times.I am running out of ideas. Need some help. Thanks for the help.
Helpful Details Below :
1995 mitsubishi mighty max pickup


If it idles fine and revs there probably and most likely will Not be a problem with the exaust being clogged up.

Your engine timing can be off.

You can have a bad camshaft sensor.

You can a bad crankshaft sensor, this will usually not let the vehicle start at all, but when going bad it can.

You can have a bad TPS(Throttle Position Sensor)

The sputter then rev during idle is a symptom of a bad TPS, the vehicle is 16 years now and the TPS if never changed would likely be No Good.

You throttle body, that can be dirty and just need to be cleaned, your IAC(Idle Air Control) needs to be checked and the port cleaned.

What you can do first is take it to Auto Zone or Advanced Auto Parts and have them get the codes out of it, they do this for Free, Auto Zone may have stopped doing it but do check.

Get the codes and get back to me.

This would be the first thing.

You can clean the throttle body, remove the IAC and clean the port and see if that works first if you are in a bind where you can go to the store right now.

You can also drop the exaust so just the front pipe is on and you are free flowing for sure to test for it being clogged. It would will be loud but it will tell you if it is clogged up. I do doubt it though.

Get back to me with the codes, let me know what the store said the codes mean, if they sat TPS or Camshaft sensor, you should price them out.

We can go from there.

have not been able to get it to auto parts store. Trying today. I took off the tps and it fell apart in my hands.I installed a new tps and the results were the same. If I rev the engine it revs ok. This is with the converter off exhaust. Free flow. But if I just stomp on the gas while its in park it just boggs down to the point of where it wants to cut off but not. Trying to get it to the store but don't have a way yet. Working on it. Dadd3/20/2011 11:34:00 AM370

could this still be an injector problem. Dadd3/20/2011 2:19:00 PM372


Ok the tps fell apart so that was no good and that was replaced.

You checked the exaust, go ahead and put that back on.

Now the next problem can be your fuel regulator, look on the fuel rail for it, it will be near where the fuel enters the rail, after running it take the vacuum line off and see if Gas comes out of it or it is wet inside the vacuum line.

That would let it dump fuel into the intake an bog it out, this is about the time this stuff is going to start going bad.

The more you press on the pedal the more gas your going to call for, if the regulator is bad it will bypass the fuel rail and suck it through that line and you will bog out like you have no fuel, the feathering will let some fuel pressure back into the rail letting you run.

You would also be running to mush fuel into the wrong cylinders at the wrong time causing the backfiring and also raw fuel into the exaust.

Check on that and let me know.

I do not suspect and injector problem.

Please press the Satisfied button if you are satisfied with the experts answer so him or her can be compensated for thier time. Thank You AnswerRack. Com
MasterMech3/20/2011 4:31:00 PM373

ok I ran the truck and pulled off the vacuum line and the engine tried to shut down but not and then I plugged it back in and it went back to ok at idle. There were no signs of fuel or any liquid in the hose. Dadd3/21/2011 11:53:00 AM376


It can still be the Fuel Pressure Regulator, you really have to get the codes as I mentioned.

Your also need to test the fuel pressure with a tester.

There isn't much more that I can get away with without you getting the codes or buying a regulator.

If your codes were to come up let's say with a "Lean Condition" on Bank1 and Bank2, I could recomend a regulator, sometimes codes will come up with 5 different fixes, then you go on to try to pinpoint the problem out of those 5 "Hints" you can even call them.

Let me ask you this, the snorkal or tubing that goes to the throttle body for the air to go through, is that cracked anywhere, there also is a Mass Air Flow Sensor on that intake air snorkal tube, that tube can't be cracked or have any cracks in it, if it is ribbed you need to check inside the ribs.

Check that the MAF is opening also when you are reving it, you can tap on that sometimes and it may work again if it were defective. Make sure the wiring is good on it.

Check every fuse that you can find, especially a fuse marked MAF

You can get a cheap fuel pressure tester at walmart and follow the directions on using it.

You can actually remove the snorkal at the throttle body and try reving it and listen for a difference.

With the snorkal off you can try spraying Carburetor Cleaner in the throttlebody while reving it and see if it Picks Up insteaded of boggs out.

You can try those things until you can get to the store.

kinda of strange but I pulled the truck out and tried to drive it. It sputtered like always then I started just a stomping on the pedal, it got a little better then I did this like 5 times got the truck up to 55mph took 2 days but thats improvement. Not good but still more than before. Also where is the port to plug the computer into.I didn't see anything under the steering wheel area for a plug in. Dadd3/21/2011 4:42:00 PM380

Look above where the gas pedal is, up under the dash for the data connector.

Your new TPS is probably giving you a better pedal response.

i do not see the connector above the gas pedal but I do see a connector behind and above the parking brake it has 3 male pins is that the obd 1 since this is a 1995? Also I went and drove the truck again. If I drive down the road in D it sputters when I press the gas and I feather it, the softer I press the pedal the better it drives finally getting to about 45mph. But if I just stomp on it it boggs down. Know I stop and put it in first and I stomp the gas, it sputters and then runs a whole lot better and then I shift into 2nd and it goes ok then when I go to D and stomp it it bogs down. Believe i'm going to go ahead and get the fuel pressure regulator. It would make sense to me that if i'm featherin it it is getting just enough fuel to respond and when I stomp it it just bogs. What about the fuel return line?Any going to try the regulator.I called autozone and they said their were no codes for the maintenance light.I can probably get it there now but will it record any codes. The only time I got a check engine light was when I unplugged the mass air flow. Still going to take it there or advance see what they can do. Dadd3/22/2011 11:52:00 AM386


Yes bring it to advance, If the connector is black it may be the obd but they were always above the gas pedal, they will find it.

See if you can try pinching the rubber return line that comes off the engine headed back to the tank while you rev it in park and see if you get a difference, just watch you don't split it, make sure it is plyable enough to pinch first, just do this as a test.

Don't leave it pinched.

advance auto told me they couldn't read obd1 they said I had to take it to a dealer. Did order the regulator be here tomorrow. Dadd3/23/2011 3:12:00 PM388

one of the customers told me something about jump 1st and last pin use an old school analog meter and I could get the codes. Dunno bout that. Cant seem to find a obd1 scanner anywhere without going to a shop or dealerdadd3/23/2011 5:25:00 PM389


I have a way here and the connector would be by the kick panel, I did think that was obd2 not one.

Here is what you can do:

Getting the check engine light codes for Mitsubishi vehicles requires using an analog voltmeter (this voltmeter has needle to read the voltage). To read the code, shut engine off and connect the voltmeter leads to the diagnostic output connector located under the dash panel in the driver’s side by the kick panel.

The diagnostic output connector has 12 terminal pins but connect the positive lead of the voltmeter to the top right corner terminal called MPI diagnosis (pin 1) and the negative lead of the voltmeter to the lower left corner terminal called ground terminal (pin 12). Once connected, turn the key on without starting and watch the dash panel flash the codes. To read the codes, use this guide:

Code 12 is one long sweep of the needle followed by 2 short sweeps. If there are more codes, there is a 2 seconds pause between codes. Most models before 1988 use a single digit codes but after that, it is mostly a 2 digit codes. To clear the codes after removing the voltmeter, remove the battery negative terminal for 15 seconds.

ok first off new fuel pressure regulator no dice. It was pretty rusty on the outside of the old regulator but anyway. The fuel line that goes into the fuel regulator is from the tank right? When I turn the key to on. Shouldn't I get fuel out of the hose from the tank to the regulator? Didn't have any. Or does the regulator come out of the engine back to the tank? Also the only 12 pin connector that I can find plugs into a small black box about 4x5x1 inches. Is that the one. It is located behind kicker panel up on roof under dashboard back left then up?Dadd3/24/2011 6:01:00 PM391

The line that comes from your fuel filter up to the engine would got to the regulator.

The 12 pin connector would be mounted where you said with wires coming out of one side of it and those wires would lead to you computer/ecm whick would be about the size of the box you spoke of.

The connector would be open though like somebody could plug something into it or forgot to plug some thing into it.

when I took the fuel hose off of the regulator and turned the key. Shouldn't that turn on the fuel pump and send fuel up that line? Hose looked dry. Dadd3/25/2011 3:26:00 AM393

It should if you left it on, I'll look at the schema and see what you have on the circuit, you might have to hit start first like you were starting it. Some will do that but not all.

Sorry for the time delay but I am on the east coast and sign off at around 10pm est and come on around 7 to 9 am est.


Hold on and let me double check on this fuel system that you have on there.

When you pulled off the regulator and put on the new one is it somehow that you think that you crossed up fuel line or did you put the regulator back on just the way you took it off?

Do put up the codes when you get them.

took off same line that came off, never took other hose off. Finally found my meter.I came up with codes 12, 13, 14, 15, 24, 25 then I disconnected the battery and did it again I come up with 12, 13, 14, 25 what
Diagnostic Codes
Without OBD-II
11 Oxygen sensor fault.
12 Airflow sensor fault.
13 Intake air temp sensor fault.
14 Throttle position sensor (TPS) fault.
15 Idle speed control (ISC) motor position sensor fault.
21 Coolant temp sensor fault.
22 Crankshaft position (CKP) sesnor fault.
23 Camshaft position (CMP) sensor fault.
24 Vehicle speed sensor (VSS) fault.
25 Barometric (BARO) pressure sensor fault.
31 Knock sensor fault.
32 MAP sensor faulty.
36 Ignition timing adjustment signal fault.
39 Oxygen (O2) sensor fault.
41 Injector(s) fault
42 Fuel pump fault.
43 EGR fault.
44 Ignition coil (cylinders #1 & #4) fault.
52 Ignition coil (cylinders #2 & #5) fault.
53 Ignition coil (cylinders #3 & #6) fault.
55 Idle air control (IAC) valve position sensor fault.
59 Rear Oxygen (O2) sesnor fault.
61 Transaxle control module torque reduction signal fault.
62 Variable Induction control (VIC) valve position sensor fault.
71 Traction control (TC) vacuum valve solenoid fault.
72 Traction Control (TC) vent valve solenoid fault
the heck is a barometric sensor?Dadd3/25/2011 8:59:00 AM396

what is a barometric sensor fault?Dadd3/25/2011 9:02:00 AM397


Ok first you will not get any gas out of the line that is the return line to the fuel tank.

That line will just go back to the tank, the inlet line goes right to the rail from the filter.

I'll work on your codes and be back.

ok I got a question. My throttle position sensor that I took out and fell apart had a 4 pin connector and the throttle sensor had 3 pins. The 3rd pin is not used on the original. But my new unit has 4 pins. The old ones pin didn't come out, it looks like it was made that way with a plastic piece inside the connector that fills in the hole for that pin.I was still getting a throttle position sensor fault? Dunno going to unhook battery and drive and then read codes again. Also I noticed that the battery in my truck is like half the size of a normal battery. It almost looks a little larger than a lawn tractor battery but the cold crank amps on the battery are correct. Dunno. Dadd3/25/2011 9:36:00 AM399

ok reset codes again drove and I didn't get any codes.I unplugged something on top of the intake and checked to see what it was. What ever it was it came up as code 15. If the chart I saw was right then it should have been ok. Dunno, now I don't get codes. Also put new plugs in it last nightdadd3/25/2011 10:05:00 AM401

The engine should be warmed up to take the codes and taking it for a ride would be the thing to do.

Take the voltage at your battery and check that it is charging at around 13.5 to 14.5

Let me know what you get.


It just drove exactly the same as it before?

What battery voltage did you get while engine running?

Did you check the snorkal and all the other suff I mentioned in other replies?

Did you do the carb clean test?

yes, the battery has 14 volts, the code 14 keeps coming up was wondering why the old tps has 3 pins and the new has 4 pins?Dadd3/25/2011 11:45:00 AM404


You only need the 3 pins, for it to read, check the wiring, make sure that the wiring is good where it connects to the tps, there can be a contact problem or a broken wire problem.

The fourth one can be for other applications, can be used for a ground loop on other apps.

Either that or it is totally the wrong one, callthe store a double check it.

Check it all good look for cracks and damage to the insulation.

Unplug it and see what the throttle response is, then plug it in and see what the response is.

I'll look for the reference voltage.

Have you ever replaced the timing belt and have you ever checked the timing.

Also i'm looking to see the adjustment on the tps if it needs one.

have not checked the timing yet. The part is right for the truck but the other brands have 3 pins not 4. When I unplug the sensor while reving it dosen't act any different then when it is plugged in. Dadd3/25/2011 1:40:00 PM407

ok here's a good one. Ok I took off airbox and mass airflow and snorkel and drove the truck. It ran the best its ever drove. So now what? Aaahhh also for some reason it will not shift into overdrive now. Their is still a little sputter when I stomp on it but no where close to what it was. Don't understand why it wouldn't shift into overdrive. But what do I know?Dadd3/25/2011 2:29:00 PM408

also I checked the codes I got 12, 13, 14, 25 I think I know 12 is airflow meter 13 is intake air temp, 14 is tps, and 25 is barometric sensordadd3/25/2011 2:33:00 PM409

thanks so much.
Do you
have the same problem?
Friday, March 25th, 2011 AT 9:48 PM

1 Reply

When the MAF is disconnected, codes 12, 13 and 25 would be triggerred as all three conponents are inbuilt together.

Code 14 is for the TPS. Was it calibrated correctly when it was replaced?
Was this
Monday, June 20th, 2011 AT 12:58 PM

Please login or register to post a reply.

Recommended Guides