1994 Chevy Truck oxygen sensor

Tiny
CDOWD
  • MEMBER
  • 1994 CHEVROLET TRUCK
  • V8
  • 4WD
  • AUTOMATIC
  • 159,000 MILES
On my truck someone put duals on it and just straight pipes no mufflers or oxygen sensors and it is running real bad if I put it drive and hit the gas it will spin the tires but going down the highway it misses but if I get up to 65 or 70 it runs good so what do you think my problem is thanks
Do you
have the same problem?
Yes
No
Wednesday, April 8th, 2009 AT 1:35 PM

18 Replies

Tiny
BLACKOP555
  • EXPERT
May be time for tune up.

Spinning the tires? Check to make sure the ignition timing is properly set.
Was this
answer
helpful?
Yes
No
Wednesday, April 8th, 2009 AT 10:19 PM
Tiny
CDOWD
  • MEMBER
Well I have already put new spark plugs and wires what and set the timming so what do I do now
Was this
answer
helpful?
Yes
No
Wednesday, April 8th, 2009 AT 10:28 PM
Tiny
BLACKOP555
  • EXPERT
Start vehicle up and take off right away. Are symptoms there on cold engine?
Was this
answer
helpful?
Yes
No
Friday, April 10th, 2009 AT 8:52 AM
Tiny
CDOWD
  • MEMBER
Wher is the oxgen sensor harness
Was this
answer
helpful?
Yes
No
Saturday, April 11th, 2009 AT 9:20 AM
Tiny
BLACKOP555
  • EXPERT
It is connected to the oxygen sensors.
Was this
answer
helpful?
Yes
No
Saturday, April 11th, 2009 AT 3:40 PM
Tiny
CDOWD
  • MEMBER
Hey man look im not stupid what I have been trying to tell you is that none of that is there the oxagen sensor has been bypassed. And the wires are gone
Was this
answer
helpful?
Yes
No
Sunday, April 12th, 2009 AT 10:15 PM
Tiny
BLACKOP555
  • EXPERT
Thats going to be a hard one. Would you like a wiring diagram if I can find you one that way you can find whats there and what is supposed to be on your vehicle and whats not?
Was this
answer
helpful?
Yes
No
Monday, April 13th, 2009 AT 2:17 PM
Tiny
CDOWD
  • MEMBER
Yes I would but one more thing I unpluged the vacum hose off of the map sensor and it ran fine so could the map sensor on my truck make it run like a junker if it was no good?
Was this
answer
helpful?
Yes
No
Monday, April 13th, 2009 AT 3:59 PM
Tiny
BLACKOP555
  • EXPERT
The map sensor is a very important part of the efi system.

It is used in place of a MAF sensor on earlier model vehicles and it is cheaper. It will most definetely cause your vehicle to run horrible.
Was this
answer
helpful?
Yes
No
Monday, April 13th, 2009 AT 9:53 PM
Tiny
CDOWD
  • MEMBER
Ok I had to order the map sensor but now if I try to start my truck it takes along time to start and when it starts if I dont hold the gas it will not run so do you think it is the map sensor?
Was this
answer
helpful?
Yes
No
Monday, April 20th, 2009 AT 9:40 AM
Tiny
CDOWD
  • MEMBER
Will the map sensor make the truck not run
Was this
answer
helpful?
Yes
No
Monday, April 20th, 2009 AT 1:11 PM
Tiny
BLACKOP555
  • EXPERT
If the map sensor is reading improperly it wont work! Disconnect the harness from the map sensor. Run any better?

The map sensor is used in correspondence with the TPS sensor and o2 sensor for fuel delivery on your model vehcle. They are now replaced with the MAF sensor.
Was this
answer
helpful?
Yes
No
Monday, April 20th, 2009 AT 6:10 PM
Tiny
CDOWD
  • MEMBER
Yea it will run better if I disconnect it but it will not stay running and I bypassed the o2 sensor
Was this
answer
helpful?
Yes
No
Monday, April 20th, 2009 AT 7:47 PM
Tiny
CDOWD
  • MEMBER
So what do you think I sould do
Was this
answer
helpful?
Yes
No
Tuesday, April 21st, 2009 AT 11:15 AM
Tiny
CDOWD
  • MEMBER
Hello
Was this
answer
helpful?
Yes
No
Wednesday, April 22nd, 2009 AT 2:59 PM
Tiny
BLACKOP555
  • EXPERT
How long will the vehicle run for? Disconnect all sensors and see if it will run longer.

Then slowly reconnect one at a time till it stalls or runs roughly.

That component is the one with a issue.

Sorry for the slow reply.

Check engine light?
Was this
answer
helpful?
Yes
No
Wednesday, April 22nd, 2009 AT 7:47 PM
Tiny
CDOWD
  • MEMBER
It will run for about five mins then it shuts off I put it on the computer and it said the map sensor was bad
Was this
answer
helpful?
Yes
No
Thursday, April 23rd, 2009 AT 6:56 AM
Tiny
BLACKOP555
  • EXPERT
The map sensor if disconnected should still allow the vehicle to run.

Time to check the wiring harness for it and make sure it isnt damaged.
Was this
answer
helpful?
Yes
No
Thursday, April 23rd, 2009 AT 9:28 PM

Please login or register to post a reply.

Recommended Guides