My check engine light was coming on car would.

Tiny
ANONYMOUS
  • 1993 TOYOTA COROLLA
  • 112,000 MILES

My check engine light was coming on car would bog down and kill you could start it again then the same. We changed the relay and the fuel pump, ran okay for a couple of days then then same so we changed the throttle sensor and ran great the next 3 days and then same the car ran fine turned it off and now check engine light and car will turn over then kills. Have any suggestions on what could be going on without bringing to dealership and spending high $.

Tuesday, April 2nd, 2013 AT 2:17 PM

19 Replies

Tiny
KHLOW2008
  • EXPERT
  • 42,008 POSTS

Have you retrieve the trouble code for the MIL indicating?

http://www.2carpros.com/articles/toyota-trouble-code-definitions-and-code-gathering-method-1990-1995

Check above link.

Was this
answer
helpful?
Yes
No
Tuesday, April 2nd, 2013 AT 4:52 PM
Tiny
SHARONMARTINEZ
  • MEMBER

We did the paper clip thing bc auto zone said they didn't have anything to check with it did the 4 blinks than pause then 1, we change the throttle sensor it ran for 3 days then started again, we did the same thing when it wouldn't start and it just kept blinking, we also changed the ignition switch sensor today and still no help. I understand the car is old but never had this much trouble since I got it.

Was this
answer
helpful?
Yes
No
Tuesday, April 2nd, 2013 AT 5:49 PM
Tiny
SHARONMARTINEZ
  • MEMBER

Now the check engine light is very dim and just flickers

Was this
answer
helpful?
Yes
No
Tuesday, April 2nd, 2013 AT 6:54 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,008 POSTS

If the MIL is dim and filckers, it could mean power supply fault or a bad engine computer.

Check for poor ground circuits. Are you still gtting the same code?

Was this
answer
helpful?
Yes
No
Wednesday, April 3rd, 2013 AT 5:28 AM
Tiny
SHARONMARTINEZ
  • MEMBER

Computer was fixed, it starts but check engine light stays on and car still bogs down like it wants to kill and you can smell that it's not getting the right fuel mixture.

Was this
answer
helpful?
Yes
No
Wednesday, April 3rd, 2013 AT 8:07 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,008 POSTS

DId you recheck for trouble codes?

Was this
answer
helpful?
Yes
No
Thursday, April 4th, 2013 AT 4:34 PM
Tiny
SHARONMARTINEZ
  • MEMBER

Yes check engine light now just stays on and it wont give a code

Was this
answer
helpful?
Yes
No
Thursday, April 4th, 2013 AT 4:41 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,008 POSTS

The computer has not been fixed. It is faulty.

Was this
answer
helpful?
Yes
No
Thursday, April 4th, 2013 AT 5:14 PM
Tiny
SHARONMARTINEZ
  • MEMBER

OK check engine light stays on, when we pull the spark plug wire it's yellow instead of blue, car stays running but when accelerating it bogs down and wants to kill and fuel mixture smell is still off?

Was this
answer
helpful?
Yes
No
Friday, April 5th, 2013 AT 10:20 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,008 POSTS

Yellow sparks means a weak ignition coil and that can cause loss of performance but the MIL staying on, that is what you need to resolve.

Was this
answer
helpful?
Yes
No
Sunday, April 7th, 2013 AT 3:26 AM
Tiny
SHARONMARTINEZ
  • MEMBER

We also changed the IAC valve and still doing the same thing the check engine light is still on and wont throw out any codes do you think it could be a bad ECM?

Was this
answer
helpful?
Yes
No
Monday, April 8th, 2013 AT 2:03 AM
Tiny
KHLOW2008
  • EXPERT
  • 42,008 POSTS

Yes, I already told you that earlier.

Was this
answer
helpful?
Yes
No
Monday, April 8th, 2013 AT 3:46 PM
Tiny
SGMEEM69
  • MEMBER

Ok I've replaced the ECM 5 days ago and the distr cap, spark plugs and wires the car started and ran perfect for 3 days the 4th day ran ok then got in car started to drive it started sputtering and did not want to go, checked code it said 24 I changed the intake air temp sensor and the car still does the same thing. It starts and idles but once it is given gas it boggs and wants to kill what now?

Was this
answer
helpful?
Yes
No
Sunday, April 14th, 2013 AT 3:41 PM
Tiny
SGMEEM69
  • MEMBER

Ok I've replaced the ECM 5 days ago and the distr cap, spark plugs and wires the car started and ran perfect for 3 days the 4th day ran ok then got in car started to drive it started sputtering and did not want to go, checked code it said 24 I changed the intake air temp sensor and the car still does the same thing. It starts and idles but once it is given gas it boggs and wants to kill what now?

Was this
answer
helpful?
Yes
No
Sunday, April 14th, 2013 AT 4:55 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,008 POSTS

Are you getting any trouble codes now?
Have you rechecked the spark plugs etc?
Go back to basics, some of the components you have replaced could have gone bad again.

Was this
answer
helpful?
Yes
No
Monday, April 15th, 2013 AT 10:05 AM
Tiny
SGMEEM69
  • MEMBER

We still only get the 24 and we replaced that and still gives that code, we also replaced dist cap, rechecked spark plugs. The car starts and idles fine but when you give it gas it sputters like it wants to kill and the new ECM only is giving 24 nothing else and we reset and still only 24. Everyone I know is baffled that the car ran for 3 days straight no problem then turn the corner and it starts sputtering. We are still making sure all the wires are good but at an end of trying to figure out what to check next or what it could even be.

Was this
answer
helpful?
Yes
No
Monday, April 15th, 2013 AT 1:03 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,008 POSTS

Rerplacing the sensor multiple times and same codes comes up means nothign wrong with the sensor. You either have a problem with the wiring or ECM.

Refer to chart for diagnostics.

Was this
answer
helpful?
Yes
No
Tuesday, April 16th, 2013 AT 4:54 AM
Tiny
SGMEEM69
  • MEMBER

Ok the funny thing is we let the car sit for days then start it up runs great then turn it off restart start driving then it starts when you excelerate the car starts to sputter when you excelerate why?

Was this
answer
helpful?
Yes
No
Tuesday, April 16th, 2013 AT 4:51 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,008 POSTS

If the code keeps coming back, thta would mean a fautl with the wiring or ECM and you need to test to find out why.

Was this
answer
helpful?
Yes
No
Please consider a donation if we helped you
Wednesday, April 17th, 2013 AT 6:46 AM

Please login or register to post a reply.

Related Throttle Position Sensor TPS Replace/Remove Questions

Recommended articles