ALTERNATOR ISSUE

1993 Saturn SC1

Tiny

leonratzo

July, 26, 2012 AT 6:42 PM

I have a 93 sc1 with a new engine replaced about 1 1/2 years ago I am at a loss I had the original alternator go out so went to the junkyard found another had it tested and was good at 14.25 it lasted about 35 days so thinking it was from a junkyard and I have no idea how long it sat in the yard I decided to get a brand new one well here I am today 2 months later and the new alternator is now also burned up I have figured out my tale tale sign is my stereo will cut in and out (meaning turn off and back on when it is turned up to loud) and when the alternator goes out the car runs till the battery dies then shuts off completely I have checked the battery it charges and holds a charge just fine the car was lowered and has been since I bought the car in 09 all the dust shields are on and in tact any help would be greatly appreciated

Thanks,
Cory

FOUND 18 RELATED QUESTIONS

16 Answers

Tiny

saturntech9

July, 26, 2012 AT 6:51 PM

Have you checked the actual voltage at the battery at idle?Then turned on all your accessories and seen what the voltage is?I have never seen that model saturn just eat up alternators one after another and I have been working on these cars since 1993. Did the junk yard alternator test bad when you replaced it?

Tiny

leonratzo

July, 26, 2012 AT 7:00 PM

At idle battery checked at 14.35 with lights and radio on it droped to 13.10 on the meter after last alternator went out charged battery put meter on and it read 12.0 and started to decline and declined even faster when lights and radio where turned on I'm charging battery now and will test voltage when battery is charged

Tiny

saturntech9

July, 26, 2012 AT 7:08 PM

Alright keep me posted. So far the voltage looks good I would also test the voltage with the ac on also if it works head lights on high beam blower fan on high.

Tiny

leonratzo

July, 26, 2012 AT 7:16 PM

Ok ill let you know as for AC hasn't worked since I've owed the car I've checked it and the Ac compressor is bad needs replaced but has never caused an issue

Tiny

saturntech9

July, 26, 2012 AT 7:29 PM

Alright keep me posted.

Tiny

saturntech9

July, 27, 2012 AT 1:14 AM

Also when checking the voltage at the battery at idle run the high beam headlights and the blower motor on high even though the ac is inop.

Tiny

leonratzo

July, 28, 2012 AT 11:02 PM

Ok sorry for the delay at idle battery reads 12.58 with lights on and high beams on and fan on high the voltage drops to 12.10 when revved to about 2500 rpms voltage drops to 12.08 hope this will help I'm at an utter loss as to why it's burning through alternator thus far oh and that's also with the radio on as well

Tiny

saturntech9

July, 29, 2012 AT 12:35 AM

Have you checked to see if you left the fusable link loose on the alternator stud?Also what is the voltage at the battery with nothing on?

Tiny

leonratzo

July, 29, 2012 AT 12:41 AM

I'll jack it up and look again I'm almost positive it's tight and as for battery with car off it reads 12.98

Tiny

saturntech9

July, 29, 2012 AT 12:45 AM

I ment idling with nothing on voltage at the battery?

Please login or register to post a reply.

Alternator Replacement Ford Super Duty
Alternator testing done right
Alternator Replacement Chevrolet Silverado
Serpentine Belt Replacement Mercedes Benz
Serpentine Belt Replacement Acura MDX