IM NOT SHURE THE MODEL ITS A TWIN CAM 1

1993 Saturn

Tiny

Anonymous

December, 13, 2012 AT 11:16 PM

Im not shure the model its a twin cam 1.9 standerd car. They would drive it around but it would constantly stall you had to mash the pedal to the floor to start it. Well I replaced the fuel filter then it started fine ran it for about 15 to 20 min or so then got in it ready to drive it then it died it wont start now ill mah the pedal to the floor and it almost cranks then thats it. What do I test?

FOUND 1775 RELATED QUESTIONS

1 Answer

Tiny

saturntech9

December, 13, 2012 AT 11:39 PM

If its a twin cam sedan 4 doors with a trunk?Then its a SL2 that way you know in the future what you have. Sounds like a bad coolant temp sensor there two sensors screwed into the head bellow where upper radiator hose goes onto the head. Its the bottom sensor with a black wire and a yellow wire going to it. The connector you squeeze to unhook it look on the inside of the connector if the terminals are blue or green instead of silver you will need to replace the connector. Its really common for those sensors to fail I have replaced tons of them when they fail they cause hard starting no starts stalling cutting out dieing overheating surging all kinds of symptoms. The sensors are only like 10-11 I would just replace it I have have put four in my saturn in the 6.5 yrs of owning it. Get a brass tipped sensor the plastic tipped ones crack ands leak coolant into the connectors corroding them. Let me know what you find.

Please login or register to post a reply.

Brake Master Cylinder Replacement Like a Pro
Brake Shoe/Drum Replacement - Rear
Brake Pad/Rotor Replacement - Front
Brake Pad/rotor Replacement - Front