Lancer 1993 sticky gas pedal

Tiny
QSILVER
  • MEMBER
  • 1993 MITSUBISHI LANCER
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 220,000 MILES
I have checked the carburetor and it seemed at first that the cables were not sliding smoothly so I bought the "American Eagle" spray and sprayed all over the throttle's mechanical moving parts that connect to the carburetor, now it's moving somewhat freely except that it's not going all the way back(about 1/10) so the rpm's are pretty high(2500-3000) after I release the gas pedal, it seems like it's actually stuck, only by moderate force that I'm able to push it back to place(it jumps back with the sound of a metallic click).

Thanks in advance.
Michael.

Do you
have the same problem?
Yes
No
Sunday, May 8th, 2011 AT 1:45 PM

2 Replies

Tiny
RASMATAZ
  • EXPERT
Replace the accelerator cable and make sure its adjusted properly
Was this
answer
helpful?
Yes
No
Sunday, May 8th, 2011 AT 7:01 PM
Tiny
QSILVER
  • MEMBER
I'm sorry that I haven't clarified that the cables all run smoothly now.

All the visible parts move freely, the sound of the metallic click seems to be coming from somewhere inside the carburetor, I thought maybe it should be cleaned from the inside, I haven't got the skill to disassemble it though.
I just need to know the possible problem, because I suspect the place where I put the car for repair isn't trustworthy.

Thank you very much for your input rasmataz.
Was this
answer
helpful?
Yes
No
Sunday, May 8th, 2011 AT 7:28 PM

Please login or register to post a reply.

Sponsored links