ANY HEARD OF A "IDLE LEARN" PROCEDURE FOR 92 OLDS 3.1?

1992 Oldsmobile Cutlass

Tiny

bus933s

September, 15, 2012 AT 7:54 PM

92 olds cutlass supreme. Replaced ECM, made sure numbers matched, used original prom. Car starts but surges at idles from 500-1500 rpm. Dangerous to put it in gear as the brakes feel hard and car lurches forward. Can rev to over 2000 and it smoothes out sounds great. But pressing gas pedal between surge speed and getting to 2000 rpm feels like no response - the pedal presses down but there is no response until 1/3 to the floor then it jumps to 2000+rpm and smoothes out.

FOUND 4510 RELATED QUESTIONS

6 Answers

Tiny

bus933s

September, 15, 2012 AT 7:56 PM

BTW, the car ran fine until the ignition control module went out. Probably didnt need to replace ecm but did anyway out of frustration for diagnosing issue. Replaced ICM and that fixed the no-start problem. Nothing else has changed.

Tiny

bus933s

September, 15, 2012 AT 7:59 PM

Oh yeah, and the service engine light is on at idle, but once I hold it over 2000 rpm for several seconds the light goes out, until I let it idle again.

Tiny

ASEMaster6371

September, 15, 2012 AT 8:23 PM

Sounds like more of the idle air control motor.

Tiny

KHLow2008

September, 16, 2012 AT 7:33 AM

Get the trouble codes and let us know what it is.

Tiny

bus933s

September, 16, 2012 AT 2:03 PM

Thanks for the reply but after some serious snooping I found a vacuum line disconnected. Runs fine now.

Tiny

KHLow2008

September, 16, 2012 AT 4:44 PM

Glad to know it is an easy fix.

Have a nice day.

Please login or register to post a reply.

 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear - Dodge Stratus
Code Read Retrieval/Clear Chevrolet Camaro
How to gather codes Ford Explorer
Code Read Retrieval/Clear
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear Mercedes Benz