WHY DOES MY NEUTRAL SAFETY SWITCH KEEP SHOWING A...

1992 Chevrolet Lumina

Tiny

Wolfman1me

November, 18, 2012 AT 11:54 PM

Why does my neutral safety switch keep showing a fault code when it appears to be working fine. Have noticed it losing power and back firing spuraticly when cruising. Code for cam sensor also came on replaced it. No avail. Have replaced all sensors but temp, and crank. New ignition control module, and ECM(computer), plugs. What could be causing the spuratic power lose and popping and?Faulse neutral safety switch code, cause neutral safety switch is only 1yr old too.?

FOUND 243 RELATED QUESTIONS

2 Answers

Tiny

ASEMaster6371

November, 18, 2012 AT 11:55 PM

Code numbers never identify bad parts just failed systems. We need the code numbers and we can give you the flow charts for the codes.

Roy

Tiny

Wolfman1me

November, 19, 2012 AT 11:07 PM

Codes given are: DO342 cam signal circuit? Has new cam sensor, codes cleared, still comes back.
---DO705 neutral saftyswitch/trans range switch malfunction. Also new switch of one year old. Code also came back after clearing.
---PO117 Engine Coolant Temp Sensor/Low. This is cause I know I need a new thermostat after an over heat from vandals cutting radiator hose, it's most Likely stuck open cause my guage is showing low temp. This code however never came back.
? Could ECM have gone bad again? Or ---wire short from over heating?

Please login or register to post a reply.

Pulling an Auto Trans? Easy Instructions
Transmission Speed Sensor Replacement Honda