While driving in drive the car stalls as if in nuetral

Tiny
LAQUATA1
  • 1991 CHRYSLER 5TH AVENUE
  • 10,100 MILES

After letting car warm up put it in drive go a few blocks, it stalls as if its in nuetral, goes in reverse fine, but while driving it goes to nuetral mode, I have replaced the o2 an camshaft sensors 30days ago because it would shut off when it came to a stop, an it also has o rich gas smell that using alot of gas

Do you
have the same problem?
Yes
No
Thursday, December 8th, 2011 AT 6:57 PM

5 Replies

Tiny
FIXITMR
  • MEMBER

Check plugs to see if fouled. Is CEL on? Also check fuel pressure regulator for internal leakage.(Vac hose will have gas in it)

Was this
answer
helpful?
Yes
No
Thursday, December 8th, 2011 AT 7:28 PM
Tiny
RASMATAZ
  • MEMBER

Do you have a check engine light and when was last tune-up?

Have the transmission further checked and also the fuel pressure

Was this
answer
helpful?
Yes
No
Thursday, December 8th, 2011 AT 7:31 PM
Tiny
LAQUATA1
  • MEMBER

If it was the transmission would it be able to move in reverse?If I let warm up theres not much an issue, but it makes a hard*****, what is an cel, what do the plugs operate an function on the car, thanks for your help

Was this
answer
helpful?
Yes
No
Thursday, December 8th, 2011 AT 9:56 PM
Tiny
FIXITMR
  • MEMBER

You should probably just take it to a mechanic for diagnosis.

Was this
answer
helpful?
Yes
No
Friday, December 9th, 2011 AT 8:27 PM
Tiny
LAQUATA1
  • MEMBER

Took it to get diagnost no code came up, transmission check again nothing came up, going to get the fuel pressure check, thanks for all your help

Was this
answer
helpful?
Yes
No
Friday, December 9th, 2011 AT 9:53 PM

Please login or register to post a reply.

Other Engine Stall Questions