HIGH IDLE WHEN IN PARK AND THEN CUTS OFF IN GEAR

1988 Chevrolet Truck

Tiny

dj5129

August, 21, 2012 AT 1:11 AM

I have 1988 Chevy C3500 with 200,000 on it. Replaced motoer several years ago. It has always idled a little high. Never really tried to fix it, but now it has started cutting off when in gear. If you put it in gear and just and hold the brake it will start off with a slight high idlebut then starts idleling down. About the time you think its idleling right, it cuts off. I have already replaced the IAC, temp sensor in the intake, distributor and rotary button. Tested the TPS and MAP sensors. Too TBI carb off and cleanded and replaced all gaskets and fuel regulator. Checked the timing. Found no vacuum leaks. It does set any codes.

FOUND 24446 RELATED QUESTIONS

Cj Stalling When Idling

33 ANSWERS
50 IMAGES

Stalling Out

43 ANSWERS
52 IMAGES

3 Answers

Tiny

mhpautos

August, 21, 2012 AT 1:24 AM

Check PCV, isolate brake booster vacuum and see if idle alters, does it surge at all? I would also try and get an exhaust gas analyser reading, this will check mixtures ans if to lean or rich at idle this can be a problem as well.

Tiny

dj5129

August, 21, 2012 AT 1:31 AM

Have allready done the pvc and break booster vacuum. No suge at all runs perfect in park just idles a little high. As far as gas analyser I will check to see if any where does that around here. THANKS

Tiny

mhpautos

August, 21, 2012 AT 1:41 AM

Let us know what the readings are when you get then done.

Please login or register to post a reply.

 Step by Step video GMC Yukon XL 2000-2006
Read Codes Like a Pro
Code Read Retrieval/Clear
Code Read Retrieval/Clear Mercedes Benz
Code Read Retrieval/Clear Chevrolet Camaro
How to read codes Chevrolet Blazer